Bug 472703 - problem opening previously broken ftp link
problem opening previously broken ftp link
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-23 16:11 EST by Stas Sergeev
Modified: 2008-11-24 04:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 04:08:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 466423 None None None Never

  None (edit)
Description Stas Sergeev 2008-11-23 16:11:33 EST
Description of problem:
If you attempt to open the broken FTP
URL for the first time, firefox displays
the appropriate message box with an error.
This is fine. But try to open the same
URL the second time, and you see no error.
An empty FTP catalog is displayed instead.
The problem is that even if the link is
fixed on a server side (missing file added
on ftp), you cannot open it any more.
Firefox will still display an empty catalog.
To make the matters worse, it appends '/'
to the URL, even if it is a file link.
You delete it, but it keeps appending.

Version-Release number of selected component (if applicable):
firefox-3.0.4-1.fc9.x86_64
and some older ones too, since 3.0 I think.

How reproducible:
Always

Steps to Reproduce:
1. Try to open a non-existal file on some ftp
2. See the error message box, close it
3. Add the missing file on ftp
4. Try opening it again
  
Actual results:
You can't open the file any longer.
Firefox somehow remembers that it was missing.
You see an empty directory instead, but
the URL was the file link, not a directory.
Firefox keeps appending '/' to URL though.

Expected results:
Error messages, as long as the file is missing.
Opening the file, as soon as it was added.
NEVER mangling an URL by appending '/' to it.

Additional info:
This is really really very annoying bug to me. :(
I am increasing severity.
It is a problem also with the win32 builds of
firefox, btw.
Comment 1 Stas Sergeev 2008-11-23 16:30:12 EST
And in case people do not want to mess with
ftp servers, here is an alternative way to
reproduce.

Steps to Reproduce:
1. Try to open a non-existal file on some ftp
2. See the error message box, close it
3. Try to open the same URL again
4. See firefox appends '/'! Remove it, hit Enter
5. See an empty ftp directory
6. Go to step 4

Actual results:
You see an empty ftp directory, even though
the URL was the file link, not a directory.
Firefox keeps appending '/' to an URL.
You will no longer have an opportunity to
open that URL.

Expected results:
Error messages, as long as the file is missing.
Opening the file, as soon as it is there.
NEVER mangling an URL by appending '/' to it -
that's just a completely broken behaveour.
Comment 2 Matěj Cepl 2008-11-24 03:28:15 EST
Reproduce with ftp://ceplovi.cz/blbost and firefox-3.0.4-1.fc10.i386
Comment 3 Matěj Cepl 2008-11-24 03:59:38 EST
Reproduced with the upstream 3.0.4 binary. Filing upstream.
Comment 4 Matěj Cepl 2008-11-24 04:08:04 EST
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=466423) and believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.