Bug 472735 - qmf-agent crashes when qpidd broker running and/or qpid-tool is invoked
qmf-agent crashes when qpidd broker running and/or qpid-tool is invoked
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.1
All Linux
medium Severity medium
: 1.1
: ---
Assigned To: messaging-bugs
Jeff Needle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 04:16 EST by Frantisek Reznicek
Modified: 2015-11-15 19:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 10:06:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Reznicek 2008-11-24 04:16:33 EST
Description of problem:
qmf-agent example crashes/cores when qpid-tool is invoked and/or an qpid-tool command is issued.
After that I could also see that qmf-agent was crashing itself (without qpid-tool, just having broker in daemon mode running).
qmf-agent doesn't core when run stand-alone (no broker running)

Version-Release number of selected component (if applicable):
  qpidd-0.3.719671-1.el5, 
  qmf-0.3.719671-1.el5, 
  rhm-0.3.2804-4.el5, 
  python-qpid-0.3.719419-2.el5
qmf-agent checkout-ed from svn branch at rev:
  720133   711933 tross        example.cpp

How reproducible:
100% using above mentioned packages on RHEL 5.2 x86_64

Steps to Reproduce:
0. compile qmf-agent
1. start qpidd (service qpidd start)
2. start qmf agent (cpp/examples/qmf-agent/qmf-agent)
3. start in another console qpid-tool


Actual results:
qmf-agent cores in 1-2 secs

Expected results:
qmf-agent should be running independently on qpid-tool commands issued.

Additional info: (backtrace)

(gdb) bt
#0  0x00002adc7ff4fd30 in qpid::management::ObjectId::encode () from /usr/lib64/libqpidcommon.so.0
#1  0x00002adc7ff4fe00 in qpid::management::ManagementObject::writeTimestamps () from /usr/lib64/libqpidcommon.so.0
#2  0x00000000004077ff in qmf::org::apache::qpid::agent::example::Parent::writeProperties (this=0x15c43670, buf=@0x414d4f70)
    at gen/qmf/org/apache/qpid/agent/example/Parent.cpp:172
#3  0x00002adc7fb88a8d in qpid::management::ManagementAgentImpl::periodicProcessing () from /usr/lib64/libqmfagent.so.0
#4  0x00002adc7fb88fbd in qpid::management::ManagementAgentImpl::PublishThread::run () from /usr/lib64/libqmfagent.so.0
#5  0x00002adc7ff0811a in qpid::sys::AbsTime::AbsTime () from /usr/lib64/libqpidcommon.so.0
#6  0x000000350bc062f7 in start_thread () from /lib64/libpthread.so.0
#7  0x000000350b0d1b6d in clone () from /lib64/libc.so.6

Detected by RHTS qpid_test_qmf_agent_bz470167 test.
Comment 1 Ted Ross 2008-11-24 08:59:54 EST
I suspect that this happened because you built the qmf-agent example against the SVN checkout (720133) and ran it against the shared-object library installed from the RPM (719671).  There was a change to the implementation of qpid::management::ManagementObject between these two SVN versions.
Comment 2 Frantisek Reznicek 2008-11-24 10:06:29 EST
Indeed, qmf-agent example from trunk was run against installed RPM set.
RHTS qpid_test_qmf_agent_bz470167 test upgraded to avoid such combination.
->NOTABUG

Note You need to log in before you can comment on or make changes to this bug.