Bug 472764 - let mkinitrd default to recreating the initrd for the currently running kernel
let mkinitrd default to recreating the initrd for the currently running kernel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.4
s390x Linux
medium Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 09:03 EST by Karsten Hopp
Modified: 2014-09-15 20:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: mkinitrd-5.1.19.6-82
Doc Type: Enhancement
Doc Text:
In order to simplify the process of adding a new direct access storage device (DASD), running a mkinitrd command without parameters now prompts the user to re-create the initial RAM disk for the currently running kernel in the /boot directory.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:23:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add kernel and target defaults (556 bytes, patch)
2008-11-24 09:03 EST, Karsten Hopp
no flags Details | Diff

  None (edit)
Description Karsten Hopp 2008-11-24 09:03:45 EST
Created attachment 324474 [details]
patch to add kernel and target defaults

Description of problem:
System administraters on mainframes regularily have to add some storage to the system and on mainframe you'll have to create a new initrd with the new DASD settings. One of our customers complained on the main s390-linux list that mkinitd on SLES uses those defaults whereas our mkinitd doesn't.

This might be useful on other archs, too.

Steps to Reproduce:
1. run mkinitrd without parameters -> usage info

Additional info:
  patch attached
Comment 1 RHEL Product and Program Management 2013-05-01 02:47:31 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2014-01-22 11:35:18 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Alexander Todorov 2014-04-16 07:39:09 EDT
Tested with RHEL5.11-Server-20140416.0.n

# mkinitrd
This will re-create the initrd in /boot for the currently running kernel.
Continue ? (y/n) y
#
# reboot

Result:
- initrd created
- system boots

Verified that running mkinitrd without parameters recreates the initrd for the currently running kernel instead of printing usage info
Comment 6 errata-xmlrpc 2014-09-15 20:23:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1224.html

Note You need to log in before you can comment on or make changes to this bug.