Bug 472768 - F10 Preview Live Plymouth graphical boot fails badly on Intel 865G
F10 Preview Live Plymouth graphical boot fails badly on Intel 865G
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-11-24 09:20 EST by James Derrick
Modified: 2008-11-26 05:19 EST (History)
3 users (show)

See Also:
Fixed In Version: 10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-26 05:19:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Derrick 2008-11-24 09:20:05 EST
Description of problem:
F10 Preview fails to set up the graphical boot console and results in a blank flashing black screen with no means of debug (tried Plymouth suggestions in the release notes). 

Version-Release number of selected component (if applicable):
Fedora-10-Preview-i686-Live Fedora Release 9.93 (Rawhide)

How reproducible:
Every time

Steps to Reproduce:
1. Boot from a USB key on an P42.5GHz with Intel 82865G integrated graphics controller + LCD 1440x900
Actual results:
White, cyan, blue lines replace the boot debug text.
The screen blanks, fails to initialise and results in a blank flashing black screen with no means of debug. Plymouth may have wrongly sensed the LCD panel and is attempting to select a screen res that is not available. A corrupt but stable display can be seen if the LCD is swapped for a CRT monitor.

Expected results:
Machine with a usable console, ideally with a means of debug. :-)

Additional info:
Hardware is a P4i65G board with 82865G graphics and a 1440x900 LCD panel. 

This is one of a number of test machines, and works with F9 using the 'Intel - Experimental mode setting driver'.
ISTR changing the Intel driver when installing F9 to get DPMS sensing of the LCD panel resolution. Stock F9 worked fine, but at a lower res (1024x768?).

Tried several means of getting more debug information:

1. Hit TAB at GRUB menu on 'Boot' option and edit the kernel parameters to remove 'quiet rhgb' to get boot messages. This gives some information, but as ^S/ ^Q don't work and ^PgUp doesn't pause, it is impossible to see what is happening without a high-speed video camera!

2. Editing the kernel parameters to add 'nomodeset' gives the textual boot messages, but the screen still ends up black and flashing every ~2S.

3. CTL-ALT-Backspace has no noticeable effect. ALT-F1 - ALT-F7 has no noticeable effect (I understand X has moved from console 7->1) .

4. CTL-ALT-DEL drops back to a text console showing services being halted.

5. Adding 'vga=0x318' to GRUB kernel parameters displays a pretty animation, but the screen still ends up black and flashing every ~2S.

6. Swapping the LCD panel for 17" CRT gets a partially corrupt login screen. The mouse works, however the bottom status panel is corrupt, and 'Log In' does nothing. Other virtual consoles are also inaccessible (e.g. CTL-ALT-F2).

7. Booting with 'nomodeset' on a 17" CRT gets to a differently corrupt login screen, with no backdrop, a full status panel and a only partial login window. The mouse works, but the keyboard does not - suggest X has crashed. CTL-ALT-BACKSPACE does not restart X.

The USB key containing F10 preview is verified on other hardware with different graphics.

I'm used to debugging X11, however a means of turning off the graphical boot is needed to get a console to start work.
Comment 1 Bug Zapper 2008-11-26 00:51:39 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 2 James Derrick 2008-11-26 05:19:22 EST
Retesting using the released F10 i686 CD (both Gnome and KDE) shows no issues.

The test machines that failed using F10 Preview with both LCD and CRT monitors all now auto-detect the display correctly and display both graphical boot and working desktop.

Note You need to log in before you can comment on or make changes to this bug.