Bug 472776 - anaconda ignore kickstart bootloader append option
anaconda ignore kickstart bootloader append option
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 10:17 EST by Jean-Francois Saucier
Modified: 2008-11-24 15:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 13:50:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Francois Saucier 2008-11-24 10:17:39 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc9 Firefox/3.0.4

A kickstart with the following line in it will result in "rhgb quiet" to being appended in grub after the install :

bootloader --location=partition --driveorder=sda,sdb --append=""


More, if I check the anaconda-ks.cfg after the install, the line is present in it :

bootloader --location=partition --driveorder=sda,sdb --append="rhgb quiet"

Reproducible: Always

Steps to Reproduce:
1.Make a kickstart with the line in it
2.Boot the installer with the kickstart file
3.Make the install and reboot
Actual Results:  
Check that grub has "rhgb quiet" appended

Expected Results:  
grub have no append like it is specified in the kickstart file
Comment 1 Chris Lumens 2008-11-24 13:50:11 EST
This is actually working as designed.  anaconda adds the "rhgb quiet" boot arguments itself, which is why they show up in your grub.conf.  We probably shouldn't write them out to the anaconda-ks.cfg though since they're not really extra arguments.  Your --append="" is working - it's just appending nothing to the arguments list.
Comment 2 Jean-Francois Saucier 2008-11-24 14:48:25 EST
Ok, thank you for your answer.

Just to know, why anaconda add it itself? Apart from scripting, there is no way to remove the options from grub?
Comment 3 Chris Lumens 2008-11-24 14:57:44 EST
We add them because those are the options we feel are appropriate for most users.  And yes, you will probably have to write a little blurb in a %post script to remove them.  booty might be helpful here, but might also be more trouble than it's worth.
Comment 4 Jean-Francois Saucier 2008-11-24 15:32:01 EST
Ok, thank you for the explanation, I will add this little one-liner to my kickstart :

sed 's/ rhgb quiet//g' /boot/grub/grub.conf > /boot/grub/grub.conf.temp && mv -f /boot/grub/grub.conf.temp /boot/grub/grub.conf

Note You need to log in before you can comment on or make changes to this bug.