This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 472808 - RFE: Hashing enhancements
RFE: Hashing enhancements
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-nss (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 14:08 EST by Miloslav Trmač
Modified: 2010-04-14 15:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-14 15:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2008-11-24 14:08:30 EST
Version-Release number of selected component (if applicable):
python-nss-0.1-1.fc10

It would be nice to be able to do the following through python-nss:
* Compute hashes incrementally (using an interface similar to Python's hashlib
  module).  Storing 100MB of data in memory only to hash it is rather wasteful.
* Compute HMAC authentication codes.
Comment 1 John Dennis 2010-04-12 10:44:04 EDT
Since this RFE was first filed python-nss has added more support for hashing, however it did not include a "feed" interface. I'm in the process of adding a number of new features to python-nss which should be available soon. I'll make sure the next release has this functionality. I may ask you to test it before I officially release it :-)
Comment 2 John Dennis 2010-04-14 15:32:23 EDT
Apparently my memory is failing me :-) This functionality was already implemented and has already been pushed out in python-nss-0.8.

see /usr/share/doc/python-nss-0.8/examples/digest_test.py for an example of how to use it.

Note You need to log in before you can comment on or make changes to this bug.