Bug 472825 - Netbeans package should require package jakarta-commons-logging
Netbeans package should require package jakarta-commons-logging
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: netbeans (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Victor G. Vasilyev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 16:39 EST by Charles Simpson
Modified: 2008-12-21 03:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 03:28:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Simpson 2008-11-24 16:39:41 EST
Description of problem:

Netbeans (in particular, netbeans-ide9) should require jakarta-commons-logging when installing.  The installation provides a (broken) symlink from /usr/share/netbeans/ide9/modules/ext to /usr/share/java/commons-logging.jar.  The symbolic link is satisfied if jakarta-commons-logging is installed.


Version-Release number of selected component (if applicable):

6.1-9


How reproducible:

Whenever jakarta-commons-logging is not already installed.


Steps to Reproduce:
1. Do not previously install jakarta-commons-logging
2. Install Netbeans
3. Build a Netbeans rich client application
  
Actual results:

Rich client application does not build because a required JAR is not present.


Expected results:

Rich client application builds.


Additional info:
Comment 1 Victor G. Vasilyev 2008-11-25 14:37:27 EST
Charles,

Thanks for the bug. Some time ago I noticed this missed dependency too
http://wiki.netbeans.org/FedoraPackagingNBWishList#section-FedoraPackagingNBWishList-JakartaCommonsLogging
:-(

WORKAROUND:
Install the jakarta-commons-logging manually via the command:
$ yum install jakarta-commons-logging

The bug is fixed in the rawhide.
Successful koji build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=950395

Changes:
- Explicit dependencies on the jakarta-commons-logging package are added (#472825).
- Summary is fixed according to the request of Richard Hughes <hughsient@gmail.com>.
- Call of the brp-java-repack-jars script is disabled.
- The deprecated key "Encoding" is removed from the desktop file template.


Note, according to the PackageMaintainers/MaintainerResponsibility [1] the fix will be pushed to F10 after a few days if it builds and works fine.


[1] https://fedoraproject.org/wiki/PackageMaintainers/MaintainerResponsibility#Miscellaneous_Items
Comment 2 Bug Zapper 2008-11-26 00:53:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fedora Update System 2008-12-01 08:03:52 EST
netbeans-6.1-10.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/netbeans-6.1-10.fc10
Comment 4 Victor G. Vasilyev 2008-12-01 08:08:59 EST
(In reply to comment #3)
> netbeans-6.1-10.fc10 has been submitted as an update for Fedora 10.
> http://admin.fedoraproject.org/updates/netbeans-6.1-10.fc10

The bug is fixed in the F-10 branch.

Successful koji build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=965855
Comment 5 Fedora Update System 2008-12-02 20:26:50 EST
netbeans-6.1-10.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update netbeans'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10666
Comment 6 Fedora Update System 2008-12-21 03:28:26 EST
netbeans-6.1-10.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.