Bug 472845 - Dbus return an error when launch evolution from command line in rhel5-server
Dbus return an error when launch evolution from command line in rhel5-server
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.2.z
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 21:04 EST by Yolkfull Chow
Modified: 2010-10-23 02:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 19:27:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2008-11-24 21:04:45 EST
Description of problem:
Launch evolution from command line,after finish setting up an account,get following error messages:

************************
CalDAV Eplugin starting up ...

(evolution:22284): e-utils-WARNING **: No parent set, or default parent available for error dialog
commit
old group, new source
** (evolution:22284): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:22284): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.         <<<<<<<<< Dbus error
  (org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files
************************

Version-Release number of selected component (if applicable):
]# rpm -qa|grep evolution
evolution-debuginfo-2.12.3-8.el5_2.3
evolution-data-server-1.12.3-6.el5
evolution-data-server-1.12.3-6.el5
evolution-2.12.3-8.el5_2.3
evolution-connector-2.12.3-6.el5.IT227280

How reproducible:
Everytime

Steps to Reproduce:
1. launch evolution
2. create a new account
3.
  
Actual results:
Dbus return an error.

Expected results:
No error messages should show up.

Additional info:
Comment 1 Matthew Barnes 2009-03-13 13:31:08 EDT
The error message is pretty harmless though.

Just means Evolution won't be able to track network connectivity through NetworkManager, likely because NM's D-Bus service is not running.  And I doubt we enable NetworkManager by default on RHEL 5 Server.

I'm not convinced there's anything to fix in Evolution.
Comment 2 Jeff Bastian 2009-03-13 17:40:53 EDT
(In reply to comment #1)
> I'm not convinced there's anything to fix in Evolution.  


Indeed, just doing a Google search on part of the error --  "org.freedesktop.NetworkManager was not provided" -- finds people reporting this against all kinds of components.  This seems more likely a problem with NetworkManager itself.
Comment 3 Matthew Barnes 2009-03-13 19:27:20 EDT
Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.