This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 472874 - kipi-plugins package is missing kipiplugin.desktop
kipi-plugins package is missing kipiplugin.desktop
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 05:19 EST by Steve Hill
Modified: 2008-11-26 01:25 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 01:25:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Hill 2008-11-25 05:19:53 EST
Description of problem:
The kipi-plugins package does not include /usr/share/kde4/servicetypes/kipiplugin.desktop, which means DigiKam can't find the plugins.

Version-Release number of selected component (if applicable):
kipi-plugins-0.2.0-0.4.beta3.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. Install kipi-plugins
2. Start DigiKam
3. Go to "Configure DigiKam" and observe that the Kipi plugins are not found
  
Actual results:
DigiKam can't see the kipi-plugins

Expected results:
The kipi-plugins should be found by DigiKam.

Additional info:
Comment 1 Lukáš Tinkl 2008-11-25 05:29:46 EST
Going to have a look
Comment 2 Rex Dieter 2008-11-25 07:52:02 EST
Odd, kipi-plugins were found ok here last I checked (x86_64).  I too, will (double) check.

Fwiw, word on the street is that a new beta4 is coming "real soon".
Comment 3 Rex Dieter 2008-11-25 08:02:52 EST
OK, Lukáš "Sherlock Holmes" found the missing kipiplugin.desktop, it's in kdegraphics.

Looks like we need to move that file to kdegraphics-libs (runtime libs), so apps using libkipi (and friends) function properly.
Comment 4 Rex Dieter 2008-11-25 08:15:10 EST
In short, until we fix this properly, quick-n-dirty fix in the meantime is: 
yum install kdegraphics
Comment 5 Steve Hill 2008-11-25 08:28:37 EST
Doh...  I did a yum search and nothing turned up.  Oh well.  My quick and dirty fix was to copy the file from a Fedora 8 machine :)
Comment 6 Rex Dieter 2008-11-25 09:20:29 EST
kdegraphics-4.1.3-2.fc10 queue'd to be included in 
https://admin.fedoraproject.org/updates/f10/FEDORA-2008-10206
Comment 7 Fedora Update System 2008-11-26 01:25:38 EST
kdegraphics-4.1.3-2.fc10, kdebase-workspace-4.1.3-6.fc10, kdelibs-4.1.3-3.fc10, kdeaccessibility-4.1.3-1.fc10, kdeadmin-4.1.3-1.fc10, kdebase-4.1.3-2.fc10, kdebase-runtime-4.1.3-1.fc10, kdebindings-4.1.3-1.fc10, kdeedu-4.1.3-1.fc10, kdegames-4.1.3-1.fc10, kdemultimedia-4.1.3-1.fc10, kdenetwork-4.1.3-1.fc10, kdepim-4.1.3-1.fc10, kdepimlibs-4.1.3-1.fc10, kdeplasma-addons-4.1.3-1.fc10, kdesdk-4.1.3-1.fc10, kdetoys-4.1.3-1.fc10, kdeutils-4.1.3-1.fc10, kde-l10n-4.1.3-1.fc10, kiconedit-4.1.3-2.fc10, kcoloredit-4.1.3-1.fc10, guidance-power-manager-4.1.3-1.fc10, konq-plugins-4.1.3-2.fc10, kdeartwork-4.1.3-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.