Bug 472882 - [RFE] If password is changed update gnome-keyring with the new password.
[RFE] If password is changed update gnome-keyring with the new password.
Status: CLOSED DUPLICATE of bug 250147
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 06:50 EST by Jóhann B. Guðmundsson
Modified: 2015-03-03 17:33 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 23:52:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-11-25 06:50:27 EST
Description of problem:

Noticed when I changed passwd for a user the password stored in gnome-keyring
( it's gnome-keyring right ) did not get "updated" hence when the user logged 
in he for example had to use his old password to allow NM to connect.

So i'm wondering if it would not be smart to add to the properties field for the
user, a check box [] Reset Gnome-keyring or []Update Gnome-keyring with new password

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nils Philippsen 2008-11-25 07:53:27 EST
As the keyring is protected by the (current) user password, this can't be done from system-config-users -- the administrator usually doesn't know the password. This could probably be done in the gnome-about-me tool (System->Preferences->Personal->About Me) where users change their own passwords (as they have to type in both old and new passwords).

Changing the component to control-center.
Comment 2 Ray Strode [halfline] 2008-11-25 09:37:54 EST
well about me just runs userpasswd, but I think this might be able to be done in the pam gnome keyring pam module.

It might even already, but just not work because we don't add it to the right pam stack, not sure.

Reassigning to gnome-keyring
Comment 3 Matthias Clasen 2008-12-10 23:52:07 EST

*** This bug has been marked as a duplicate of bug 250147 ***

Note You need to log in before you can comment on or make changes to this bug.