Bug 472924 - consider switching to upstream cdrtools
consider switching to upstream cdrtools
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cdrkit (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 11:55 EST by Martin Jürgens
Modified: 2014-01-12 19:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 06:15:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2008-11-25 11:55:49 EST
Description of problem:
Some time ago there was some controversy which caused many linux distros to ship a forked cdrtools. While the development of the fork stopped and bugs are not being fixed, the upstream project at http://cdrecord.berlios.de/ is still active.

I'd love if Fedora would reconsider to switch to that project again, more information about the claims made is available here: http://cdrecord.berlios.de/private/linux-dist.html Later on it says that a review by sun lawyers will be published there.
Comment 1 TK009 2008-11-25 13:13:39 EST
This bug has been triaged
Comment 2 Harald Hoyer 2008-11-28 08:40:31 EST
The CDDL copyright is still not favoured.
Comment 3 Jörg Schilling 2009-01-24 17:31:44 EST
The cdrkit fork is in conflict woth GPL and Copyright and cannot
be legally distributed.

The original software on the other sdide is aproved free software.
There even was a full legal review done by the Sun legal department.
The result of this review is that ar are no problems. Sun distributes
the original software.

I strongly recommend RedHat to upgrade to the origial cdrtools
in order to become legal.

The CDDL is an aproved free license.
Comment 4 Martin Jürgens 2009-05-06 10:23:00 EDT
whats the reason for closing it wontfix?
Comment 5 Roman Rakus 2009-05-06 10:26:45 EDT
Said in comment #2
Comment 6 Martin Jürgens 2009-05-06 12:21:10 EDT
is a different free license really a reason for not shipping a tool which is being actively mantained and has more features than the current one?
Comment 7 Roman Rakus 2009-05-07 08:29:07 EDT
Yes, it is. At the least, it is not acceptable in fedora. CDDL alone is not bad, but:
1) https://www.redhat.com/archives/fedora-legal-list/2007-August/msg00023.html
2) https://www.redhat.com/archives/fedora-legal-list/2009-January/msg00024.html
3) http://fedoraproject.org/wiki/Licensing#Software_License_List
This is why I have to closing it wontfix.
Comment 8 Jörg Schilling 2009-05-07 16:47:15 EDT
Sorry, but these URLs do not point to valid information.

https://www.redhat.com/archives/fedora-legal-list/2007-August/msg00023.html

Just holds an invalid claim - there is no verification for this claim


https://www.redhat.com/archives/fedora-legal-list/2009-January/msg00024.html

Also contains an invalid claim but not verification. The URL inside
points to the claim of a troll but does not contain valid information.

http://fedoraproject.org/wiki/Licensing#Software_License_List

Is a list that contains incorrect information about the GPL compatibility
to other licenses.....


Here are some facts:

- The fork distributed by Redhat contains a hard Copyright violation
  and thus cannot be legally distributed.

- The license used by cdrtools has been veryfied by seceral lawyers
  and none of the lawyers could find any problem.

- Even the FSF confirms that linking GPL programs against CDDL libs
  is legal and the FSF is interested to see GPL software on OpenSolaris

So the question is: Why does redhat prefer to distribute illegal software
and tries to avoid a legal solution?
Comment 9 Martin Jürgens 2009-05-07 16:54:19 EDT
Jörg, didnt you want to publish the legal review of the Sun lawyers? That would help I think.
Comment 10 Jörg Schilling 2009-05-07 17:34:07 EDT
Martin, the problem with diplomacy is that sometimes your
sources don't like to be quoted. What I cann tell you however
is that (with the help from Simon Phipps from Sun), we made
an agreement with Debian and Debian will switch back to the
original software soon. The agreement was made on March 6th.

Note You need to log in before you can comment on or make changes to this bug.