Bug 472925 - tty hangs "gone - no logout" fc9 / runlevel 3
tty hangs "gone - no logout" fc9 / runlevel 3
Status: CLOSED DUPLICATE of bug 450488
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 11:59 EST by g. artim
Modified: 2009-01-05 13:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 13:29:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ps axl ; w; last ; commands (10.38 KB, application/octet-stream)
2008-12-01 11:51 EST, g. artim
no flags Details

  None (edit)
Description g. artim 2008-11-25 11:59:45 EST
Description of problem:

The problem is that if you use the tty terminal (ie boot runlevel 3)
on logoff the tty hangs, a initctl start ttyn (where n is 1.)
resurrects the tty. I've seen post about the problem but no
resolution.

Version-Release number of selected component (if applicable):

Linux ****.****.edu 2.6.27.5-41.fc9.x86_64 #1 SMP Thu Nov 13 20:29:07 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

/sbin/lspci 
00:00.0 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP55 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP55 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP55 USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP55 USB Controller (rev a2)
00:04.0 IDE interface: nVidia Corporation MCP55 IDE (rev a1)
00:05.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:05.1 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:05.2 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:06.0 PCI bridge: nVidia Corporation MCP55 PCI bridge (rev a2)
00:0a.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0d.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0f.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc ES1000 (rev 02)
02:00.0 PCI bridge: Intel Corporation 6702PXH PCI Express-to-PCI Bridge A (rev 09)
03:00.0 RAID bus controller: 3ware Inc 9xxx-series SATA-RAID
04:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit Ethernet PCI Express (rev 21)
05:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit Ethernet PCI Express (rev 21)


How reproducible:

each time. the 'w' command always shows +1 additional person logged in because the tty hangs and accounts is off by +1.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

logout and tty stays alive.


Additional info:
Comment 1 Chuck Ebbert 2008-11-27 00:45:22 EST
I can't reproduce this at all. Can you run the command 'ps axl' in another session and see what it shows for the hanging session?
Comment 2 g. artim 2008-12-01 11:51:47 EST
Created attachment 325256 [details]
ps axl ; w; last ; commands 

note that this am, after booting the tty (alt+cntl_f2) return to prompt but the w command shows n+1 users after logout.
Comment 3 g. artim 2008-12-01 11:54:27 EST
(In reply to comment #0)
> Description of problem:
> 
> The problem is that if you use the tty terminal (ie boot runlevel 3)
> on logoff the tty hangs, a initctl start ttyn (where n is 1.)
> resurrects the tty. I've seen post about the problem but no
> resolution.
> 
> Version-Release number of selected component (if applicable):
> 
> Linux ****.****.edu 2.6.27.5-41.fc9.x86_64 #1 SMP Thu Nov 13 20:29:07 EST 2008
> x86_64 x86_64 x86_64 GNU/Linux
> 
> /sbin/lspci 
> 00:00.0 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a1)
> 00:01.0 ISA bridge: nVidia Corporation MCP55 LPC Bridge (rev a2)
> 00:01.1 SMBus: nVidia Corporation MCP55 SMBus (rev a2)
> 00:02.0 USB Controller: nVidia Corporation MCP55 USB Controller (rev a1)
> 00:02.1 USB Controller: nVidia Corporation MCP55 USB Controller (rev a2)
> 00:04.0 IDE interface: nVidia Corporation MCP55 IDE (rev a1)
> 00:05.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
> 00:05.1 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
> 00:05.2 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
> 00:06.0 PCI bridge: nVidia Corporation MCP55 PCI bridge (rev a2)
> 00:0a.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
> 00:0b.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
> 00:0c.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
> 00:0d.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
> 00:0e.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
> 00:0f.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
> 00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
> HyperTransport Technology Configuration
> 00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address
> Map
> 00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
> Controller
> 00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
> Miscellaneous Control
> 01:05.0 VGA compatible controller: ATI Technologies Inc ES1000 (rev 02)
> 02:00.0 PCI bridge: Intel Corporation 6702PXH PCI Express-to-PCI Bridge A (rev
> 09)
> 03:00.0 RAID bus controller: 3ware Inc 9xxx-series SATA-RAID
> 04:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit
> Ethernet PCI Express (rev 21)
> 05:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit
> Ethernet PCI Express (rev 21)
> 
> 
> How reproducible:
> 
> each time. the 'w' command always shows +1 additional person logged in because
> the tty hangs and accounts is off by +1.
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> logout and tty stays alive.
> 
> 
> Additional info:
output from 'ps axl':

F   UID   PID  PPID PRI  NI    VSZ   RSS WCHAN  STAT TTY        TIME COMMAND
4     0     1     0  20   0   4044   928 -      Ss   ?          0:00 /sbin/init
5     0     2     0  15  -5      0     0 -      S<   ?          0:00 [kthreadd]
1     0     3     2 -100  -      0     0 -      S<   ?          0:00 [migration/0]
1     0     4     2  15  -5      0     0 -      S<   ?          0:00 [ksoftirqd/0]
5     0     5     2 -100  -      0     0 -      S<   ?          0:00 [watchdog/0]
1     0     6     2 -100  -      0     0 -      S<   ?          0:00 [migration/1]
1     0     7     2  15  -5      0     0 -      S<   ?          0:00 [ksoftirqd/1]
5     0     8     2 -100  -      0     0 -      S<   ?          0:00 [watchdog/1]
1     0     9     2  15  -5      0     0 -      S<   ?          0:00 [events/0]
1     0    10     2  15  -5      0     0 -      S<   ?          0:00 [events/1]
1     0    11     2  15  -5      0     0 -      S<   ?          0:00 [khelper]
1     0    68     2  15  -5      0     0 -      S<   ?          0:00 [kintegrityd/0]
1     0    69     2  15  -5      0     0 -      S<   ?          0:00 [kintegrityd/1]
1     0    71     2  15  -5      0     0 -      S<   ?          0:00 [kblockd/0]
1     0    72     2  15  -5      0     0 -      S<   ?          0:00 [kblockd/1]
1     0    76     2  15  -5      0     0 -      S<   ?          0:00 [cqueue]
1     0    78     2  15  -5      0     0 -      S<   ?          0:00 [ksuspend_usbd]
1     0    83     2  15  -5      0     0 -      S<   ?          0:00 [khubd]
1     0    86     2  15  -5      0     0 -      S<   ?          0:00 [kseriod]
1     0   177     2  20   0      0     0 -      S    ?          0:00 [pdflush]
1     0   178     2  20   0      0     0 -      S    ?          0:00 [pdflush]
1     0   179     2  15  -5      0     0 -      S<   ?          0:00 [kswapd0]
1     0   226     2  15  -5      0     0 -      S<   ?          0:00 [aio/0]
1     0   227     2  15  -5      0     0 -      S<   ?          0:00 [aio/1]
1     0   397     2  15  -5      0     0 -      S<   ?          0:00 [kpsmoused]
1     0   444     2  15  -5      0     0 -      S<   ?          0:00 [ata/0]
1     0   445     2  15  -5      0     0 -      S<   ?          0:00 [ata/1]
1     0   446     2  15  -5      0     0 -      S<   ?          0:00 [ata_aux]
1     0   456     2  15  -5      0     0 -      S<   ?          0:00 [scsi_eh_0]
1     0   457     2  15  -5      0     0 -      S<   ?          0:00 [scsi_eh_1]
1     0   458     2  15  -5      0     0 -      S<   ?          0:00 [scsi_eh_2]
1     0   459     2  15  -5      0     0 -      S<   ?          0:00 [scsi_eh_3]
1     0   460     2  15  -5      0     0 -      S<   ?          0:00 [scsi_eh_4]
1     0   461     2  15  -5      0     0 -      S<   ?          0:00 [scsi_eh_5]
1     0   470     2  15  -5      0     0 -      S<   ?          0:00 [kjournald]
5     0   518     1  16  -4  12876   984 -      S<s  ?          0:00 /sbin/udevd -d
1     0   802     2  15  -5      0     0 -      S<   ?          0:00 [kauditd]
1     0  1012     2  15  -5      0     0 -      S<   ?          0:00 [scsi_eh_6]
1     0  1013     2  15  -5      0     0 -      S<   ?          0:00 [scsi_eh_7]
1     0  1147     2  15  -5      0     0 -      S<   ?          0:00 [scsi_eh_8]
1     0  1369     2  15  -5      0     0 -      S<   ?          0:00 [kstriped]
1     0  1384     2  15  -5      0     0 -      S<   ?          0:00 [kmpathd/0]
1     0  1385     2  15  -5      0     0 -      S<   ?          0:00 [kmpathd/1]
1     0  1386     2  15  -5      0     0 -      S<   ?          0:00 [kmpath_handlerd]
1     0  1416     2  15  -5      0     0 -      S<   ?          0:00 [kjournald]
5     0  1869     1  16  -4  23200   800 epoll_ S<sl ?          0:00 auditd
4     0  1871  1869  12  -8  16364   788 futex_ S<sl ?          0:00 /sbin/audispd
5     0  1889     1  20   0 119764  1656 select Sl   ?          0:00 rsyslogd -c 3
1     0  1901     1  20   0   6840   504 -      Ss   ?          0:00 irqbalance
5    32  1908     1  20   0  18764   776 -      Ss   ?          0:00 rpcbind
5    29  1932     1  20   0  14448   904 -      Ss   ?          0:00 rpc.statd
5     0  1961     2  15  -5      0     0 -      S<   ?          0:00 [rpciod/0]
1     0  1962     2  15  -5      0     0 -      S<   ?          0:00 [rpciod/1]
1     0  1969     1  20   0  53160   868 -      Ss   ?          0:00 rpc.idmapd
5    81  1982     1  20   0  23896   944 -      Ss   ?          0:00 dbus-daemon --system
1     0  2027     2  15  -5      0     0 -      S<   ?          0:00 [nfsiod]
1     0  2032     2  15  -5      0     0 -      S<   ?          0:00 [lockd]
1     0  2050     1  20   0  21140  1404 select Ssl  ?          0:00 pcscd
5    68  2065     1  20   0  29944  4572 -      Ss   ?          0:00 hald
5     0  2068     1  20   0 100712  2704 sys_po Ssl  ?          0:00 /usr/sbin/console-kit-daemon
0     0  2069  2065  20   0  17836  1172 -      S    ?          0:00 hald-runner
0     0  2154  2069  20   0  19948  1156 -      S    ?          0:00 hald-addon-storage: polling /dev/sr0 (every 16 sec)
0     0  2172  2069  20   0  19948  1148 -      S    ?          0:00 hald-addon-input: Listening on /dev/input/event1
5     0  2190     1  20   0  26312  1748 -      Ss   ?          0:00 /usr/sbin/hcid -s -x
1     0  2199     2  15  -5      0     0 -      S<   ?          0:00 [btaddconn]
1     0  2201     2  15  -5      0     0 -      S<   ?          0:00 [btdelconn]
5     0  2212     2  10 -10      0     0 -      S<   ?          0:00 [krfcommd]
5     0  2256     1  20   0  63348  1256 -      Ss   ?          0:00 /usr/sbin/sshd
5    38  2264     1  20   0  27652  1552 -      Ss   ?          0:00 ntpd -u ntp:ntp -p /var/run/ntpd.pid -g
5     0  2279     1  20   0   6556   512 -      Ss   ?          0:00 /usr/sbin/gpm -m /dev/input/mice -t exps2
1     0  2287     1  20   0 101828  1256 -      Ss   ?          0:00 crond
1     0  2296     1  20   0  81804  1412 -      Ss   ?          0:00 kerneloops
5     0  2308     1  20   0  23348   484 -      Ss   ?          0:00 /usr/sbin/atd
5   498  2317     1  20   0  23436  1504 -      Ss   ?          0:00 avahi-daemon: running [genepi.local]
1   498  2318  2317  20   0  23308   480 -      Ss   ?          0:00 avahi-daemon: chroot helper
5     0  2326     1  20   0 158000  2740 -      Ss   ?          0:00 cupsd
4     0  2343     1  20   0 103712  3328 -      S    ?          0:00 /usr/bin/perl /root/timeout
4     0  2503     1  20   0  58636  2624 -      Ss   ?          0:00 /usr/libexec/postfix/master
4    89  2506  2503  20   0  58716  2556 -      S    ?          0:00 pickup -l -t fifo -u
4    89  2507  2503  20   0  58780  2712 -      S    ?          0:00 qmgr -l -t fifo -u
1     0  2509     1  20   0 120892  8660 -      Ss   ?          0:00 /usr/bin/swatch --tail-file=/var/l
0     0  2510  2509  20   0  85668   692 -      S    ?          0:00 /usr/bin/tail --follow=name -n 0 /var/log/secure
4     0  2513     1  20   0   3884   536 -      Ss+  tty4       0:00 /sbin/mingetty tty4
4     0  2514     1  20   0   3884   536 -      Ss+  tty5       0:00 /sbin/mingetty tty5
4     0  2516     1  20   0   3884   540 -      Ss+  tty3       0:00 /sbin/mingetty tty3
4     0  2518     1  20   0   3884   540 -      Ss+  tty6       0:00 /sbin/mingetty tty6
4     0  2796     1  20   0   3884   540 -      Ss+  tty2       0:00 /sbin/mingetty tty2
4     0  2815     1  20   0   3884   536 -      Ss+  tty1       0:00 /sbin/mingetty tty1
4     0  2913  2256  20   0  94864  3424 -      Ss   ?          0:00 sshd: gartim [priv]
5   500  2916  2913  20   0  95016  1892 select S    ?          0:00 sshd: gartim@pts/1
0   500  2917  2916  20   0  88816  1900 wait   Ss   pts/1      0:00 -bash
4     0  3064  2256  20   0  94864  3440 -      Ss   ?          0:00 sshd: pbronson [priv]
5   521  3067  3064  20   0  95020  1880 -      S    ?          0:00 sshd: pbronson@pts/0
0   521  3068  3067  20   0  89836  1864 -      Ss   pts/0      0:00 -bash
4     0  3247  2256  20   0  94864  3432 -      Ss   ?          0:00 sshd: pbronson [priv]
5   521  3249  3247  20   0  95212  2088 -      S    ?          0:00 sshd: pbronson@pts/2
0   521  3250  3249  20   0  89836  1864 -      Ss+  pts/2      0:00 -bash
0   521  3374  3068  20   0 118124 11580 -      S+   pts/0      0:00 emacs -nw mystats
4    89  3426  2503  20   0  61396  3552 -      S    ?          0:00 smtpd -n smtp -t inet -u -o stress  -s 2
4    89  3429  2503  20   0  58708  2576 -      S    ?          0:00 anvil -l -t unix -u
4    89  3431  2503  20   0  58856  2736 -      S    ?          0:00 cleanup -z -t unix -u
4    89  3432  2503  20   0  59004  3300 -      S    ?          0:00 local -t unix
4    89  3436  2503  20   0  58724  2600 -      S    ?          0:00 trivial-rewrite -n rewrite -t unix -u
4    89  3437  2503  20   0  58692  2560 -      S    ?          0:00 proxymap -t unix -u
4    89  3441  2503  20   0  58916  2892 -      S    ?          0:00 smtp -t unix -u
0   500  3443  2917  20   0  86440   920 -      R+   pts/1      0:00 ps axl

output from w:

 08:43:04 up 57 min,  6 users,  load average: 0.00, 0.00, 0.00
USER     TTY      FROM              LOGIN@   IDLE   JCPU   PCPU WHAT
pbronson pts/0    adsl-67-119-2-57 08:16    2.00s  0.38s  0.23s emacs -nw mysta
gartim   pts/1    static-128-32-10 07:55    0.00s  0.03s  0.00s w
pbronson pts/2    adsl-67-119-2-57 08:28    5.00s  0.13s  0.13s -bash

output from last:

pbronson pts/2        adsl-67-119-2-57 Mon Dec  1 08:28   still logged in   
pbronson pts/0        adsl-67-119-2-57 Mon Dec  1 08:16   still logged in   
gartim   pts/1        static-128-32-10 Mon Dec  1 07:55   still logged in   
pramsay  pts/1        c-24-5-241-196.h Mon Dec  1 07:51 - 07:53  (00:01)    
root     tty2                          Mon Dec  1 07:50    gone - no logout 
root     tty1                          Mon Dec  1 07:48    gone - no logout 
root     tty1                          Mon Dec  1 07:48 - 07:48  (00:00)    
gthomson pts/0        adsl-71-146-73-1 Mon Dec  1 07:47 - 08:01  (00:14)    
root     tty1                          Mon Dec  1 07:46 - 07:48  (00:02)    
reboot   system boot  2.6.27.5-41.fc9. Mon Dec  1 07:45          (00:57)    
root     tty1                          Mon Dec  1 07:40 - down   (00:00)    
reboot   system boot  2.6.27.5-41.fc9. Mon Dec  1 07:39          (00:00)    
root     tty1                          Mon Dec  1 07:38 - down   (00:00)    
gartim   pts/0        c-67-160-226-111 Mon Dec  1 05:52 - 06:15  (00:22)
Comment 4 g. artim 2008-12-01 11:57:45 EST
included both as attachment and in comment section. like i said that this morning, after rebooting the tty doesn't seem to hang, but the w stats are off.
Comment 5 Jeremy Faith 2008-12-31 05:40:59 EST
I think the login not respawning is due to the problem explained in bug #450488
Comment 6 Bill Nottingham 2009-01-05 13:29:21 EST

*** This bug has been marked as a duplicate of bug 450488 ***

Note You need to log in before you can comment on or make changes to this bug.