Bug 472933 - Preupgrade-cli not working with static IP assignment
Preupgrade-cli not working with static IP assignment
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 12:36 EST by Jon Baker
Modified: 2014-01-21 18:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:08:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jon Baker 2008-11-25 12:36:25 EST
Apologies if this is already addressed but I cannot find any mention of it in any searches.

Description of problem:
My server is set with a static IP address, and I want to upgrade with VNC.  This is a test on a local system before attempting it on a headless system at a server farm.  I am in FC9, I downloaded and compiled the source for preupgrade 1.0.0-1, and ran preupgrade-cli as follows:

preupgrade-cli --vnc=[vnc_password] --ip=172.22.12.115 --netmask=255.255.255.0 --gateway=172.22.12.1 --dns=172.22.12.1 "Fedora 10 (Cambridge)"

When rebooting it appears to start anaconda, then stops on an error message "there was an error configuring your network interface" and gives me a retry button.  Clicking on the retry button brings the same error again after another NetworkManager attempt.  Of course this would not be an option on a headless system.

The grub entry is this:

title Upgrade to Fedora 10 (Cambridge)
	kernel /upgrade/vmlinuz preupgrade repo=hd:UUID=a7a5e714-c736-4be6-8ece-16fa5516721f:/var/cache/yum/ stage2=http://mirror.web-ster.com/fedora/releases/10/Fedora/i386/os/images/install.img ks=hd:UUID=b4375b45-c0a3-4b83-9f0a-ba75da35a9ec:/upgrade/ks.cfg vnc vncpassword=[vnc_password] ksdevice=link ipv6=auto ip=172.22.12.115 netmask=255.255.255.0 gateway=172.22.12.1 dns=172.22.12.1
	initrd /upgrade/initrd.img


Version-Release number of selected component (if applicable):
1.0.0-1

How reproducible:
Always

Steps to Reproduce:
See problem description
  
Actual results:
Errors out with "There was an error configuring your network interface"

Expected results:
Network should connect, VNC server should start, and upgrade should complete

Additional info:
Comment 1 Jon Baker 2008-11-25 15:45:06 EST
P.S. - this is the machine that is serving DHCP, so if it's trying to get an IP address via DHCP (by either ignoring the options or having them set incorrectly) obviously it won't be successful.  On the server at the server farm of course there is no DHCP, which is the whole purpose of this test.
Comment 2 Jon Baker 2008-11-26 15:09:36 EST
Further testing:

I installed a minimal installation of FC9 on an independent box.  I ran preupgrade-cli using a similar command as above (changing the static IP address to a different address than what DHCP is serving it).  Upon reboot, I received the same message "There was an error configuring your network interface."

I then ran 

preupgrade-cli --vnc=[vnc_password] "Fedora 10 (Cambridge)"

to see if it would work with DHCP.  Again, I recived the message "There was an error configuring your network interface."

Then I ran

preupgrade-cli "Fedora 10 (Cambridge)"

to leave everything at the defaults.  Now, on this other box there was enough room to download the install image so it technically didn't need to connect to the internet (I assume) - however, I got a different error this time.  The process got to the blue screen and then said "install exited abnormally [0/0] -- received signal 9" - whether that's related or not I am not sure.

Just for kicks I then ran

preupgrade-cli --ip=172.22.12.250 --netmask=255.255.255.0 --gateway=172.22.12.1 --dns=172.22.12.1 "Fedora 10 (Cambridge)"

That got me the "install exited abnormally" error message again.  I'm guessing that without the vnc option, it's not trying to activate the network card; neither IP address responded to any pings during the reboot.
Comment 3 Vaclav "sHINOBI" Misek 2008-11-26 15:44:08 EST
Hmm the same in my case, I run preupgrade-cli "Fedora 10 (Cambridge)" and after reboot the install stopped with "There was an error configuring your network interface".
In F9 there was NM used with two static interfaces.
I'm planning to connect the machine to the net with DHCP if it makes any difference.
Comment 4 Brian Wheeler 2008-12-01 09:29:42 EST
I had the same problem.  The work around is to modify the /boot/upgrade/ks.cfg file by adding a line like this after the "lang" line:

network --bootproto static --ip xxx.xxx.xxx.xxx --netmask xxx.xxx.xxx.xxx -gateway xxx.xxx.xxx.xxx --nameserver xxx.xxx.xxx.xxx


After the reboot it worked ok.  I wasn't using VNC, so your mileage may vary.
Comment 5 Jon Baker 2008-12-01 10:49:49 EST
(In reply to comment #4)
> I had the same problem.  The work around is to modify the /boot/upgrade/ks.cfg
> file by adding a line like this after the "lang" line:
> 
> network --bootproto static --ip xxx.xxx.xxx.xxx --netmask xxx.xxx.xxx.xxx
> -gateway xxx.xxx.xxx.xxx --nameserver xxx.xxx.xxx.xxx
> 
> 
> After the reboot it worked ok.  I wasn't using VNC, so your mileage may vary.

thanks for the tip, that did get me to the point where it initializes the network and completes the download of the install.img file.  Next it boots into anaconda, but asks me to enter a vnc password - which was set in the grub.conf and obviously can't happen on a headless system.
Comment 6 Will Woods 2008-12-04 18:24:02 EST
Did everyone here also get the message about /boot being too small? 

This only shows up when the URL for stage2=XXX is really long. As far as I can tell, the problem is that the commandline gets too long and the network configuration parameters are being cut off. 

That's why moving them into ks.cfg fixes the problem. Maybe that's the right solution to the "I need network" problem.

Oh, by the way - the commandline-network-setup stuff is only supposed to be used for VNC (remote, headless) installs. If you have local access to the machine you can just set up the network in the menus once it starts the upgrade.
Comment 7 Jon Baker 2008-12-04 18:35:10 EST
Yes, I did (In reply to comment #6)
> Did everyone here also get the message about /boot being too small? 

Yes, I did - 

> This only shows up when the URL for stage2=XXX is really long. As far as I can
> tell, the problem is that the commandline gets too long and the network
> configuration parameters are being cut off. 
> 
> That's why moving them into ks.cfg fixes the problem. Maybe that's the right
> solution to the "I need network" problem.

That makes sense, maybe the app needs to put the info into ks.cfg as well as the grub.conf file?
 
> Oh, by the way - the commandline-network-setup stuff is only supposed to be
> used for VNC (remote, headless) installs. If you have local access to the
> machine you can just set up the network in the menus once it starts the
> upgrade.

Yes, that's what I'm trying to do - only I'm testing it on a local system before trying it on a headless system, since it's much more complicated to get a headless system back when it's in a data center across the country and you're at the mercy of the tech as to when it can be rebooted; just wanted to actually see what it's going to do with the box across the room before trying it on a box across the country.
Comment 8 Jon Baker 2008-12-05 10:23:56 EST
Hey Will, I think you're right.  I got it working by doing this:

1) Run the preupgrade-cli with just the vnc option
2) Grab the stage2 URL and send it through tinyurl.com to get a small URL
3) Replace the stage2 value with the new URL, delete the ip info in the command
4) Set up ks.cfg as described above to activate the network

This time it rebooted and launched the VNC server for the upgrade.
Comment 9 Will Woods 2008-12-05 12:47:55 EST
Yeah, I can reproduce this by setting up a system with a small (or full) /boot partition and attempting a vnc-based install. The network options get cut off - you can check /tmp/anaconda.log during the install and see the truncated commandline there.

For F11 I should be able to get rid of some of the really long URLs and UUIDs on the commandline, but for now I think putting the network/vnc config in the kickstart file is the right way to go.

I'm working on an updated version of preupgrade that does that, so I may ask for testers soon.

As a side note - I thought the kernel commandline was limited to 512 characters, but these commandlines are only around 350. So either I was wrong about the kernel limit or something else (GRUB? Anaconda?) is truncating the commandline. I'll investigate that further and file a new bug if necessary.
Comment 10 Vaclav "sHINOBI" Misek 2008-12-14 06:27:44 EST
*** Bug 475027 has been marked as a duplicate of this bug. ***
Comment 11 Ray Todd Stevens 2008-12-14 21:10:35 EST
I don't know if 475037 is a duplicate of this or not.   Certainly there are some serious differences in the presentation of the bug if this is a duplicate.   But they are close enough that they might be the same thing, and either way it might be good to work on them together.

This bug seems to deal with the command line version of preupgrade not obeying information provided about the static ip.   The bug I filed is for the console based version, where there is no way to even attempt to enter this data.
Comment 12 Vaclav "sHINOBI" Misek 2008-12-15 12:57:26 EST
These setting should be used from the old instalation as far as I understand preupgrade tool, so no network informations should be entered after preupgrade is finished (during anaconda state).
Comment 13 Ray Todd Stevens 2008-12-15 15:12:19 EST
This is definitely not what happens.   Even if the previous installation has static information in place it tries to do dhcp and if the dhcp fails it just hangs up.
Comment 14 Ray Todd Stevens 2008-12-15 15:17:52 EST
This was posted to my bug marked as duplicate after it was closed so I am moving it here.

Comment #2 From  Will Woods (wwoods@redhat.com)  2008-12-15 13:33:28 EDT   (-) [reply] -------

Why do you need the network configured at all during the upgrade? Did you get
the "/boot too small" message?


First I don't get the boot to small message, but it does normally try to store a file several times the size of the 100 meg boot partition in the boot partition and fails.   Even if that is not the case it appears to try and check for updates as a part of the install process.

Either way no network means that the upgrade fails.
Comment 15 Will Woods 2008-12-15 15:33:19 EST
The problem in bug 475027 (And comment #11 through comment #14) is different from
this one. I've reopened that bug.

This bug is for trouble with preupgrade-cli and static networking, due to the
boot commandline growing too long.

Bug 475027 is for problems with preupgrade (the normal GUI) and non-DHCP
networks.

Please don't mix the two.
Comment 16 Ray Todd Stevens 2008-12-15 15:49:48 EST
Works for me.
Comment 17 Ray Todd Stevens 2008-12-15 16:10:24 EST
OK my comment 16 was in retrospect a little less than specific.   I was not referencing that the program is working for me, but instead that the comment 15 from Will was acceptable to me and that I was moving my discussion of this subject back to that bug.
Comment 18 Will Woods 2008-12-15 17:32:36 EST
Getting back to the original bug - preupgrade-1.0.1 has been built, which shortens the commandline considerably *and* puts the network configuration done in preupgrade-cli into the kickstart file. 

http://koji.fedoraproject.org/koji/buildinfo?buildID=73594

I've tested it a few times around the lab and it seems to work fine for me. If anyone can retest with that package and confirm, that would be great. 

If I don't hear anything bad I'll be pushing an update out soon.
Comment 19 Fedora Update System 2008-12-16 17:35:29 EST
preupgrade-1.0.1-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc8
Comment 20 Fedora Update System 2008-12-16 17:38:25 EST
preupgrade-1.0.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc9
Comment 21 Fedora Update System 2008-12-16 17:38:25 EST
preupgrade-1.0.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc10
Comment 22 Fedora Update System 2008-12-21 03:22:45 EST
preupgrade-1.0.1-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-11587
Comment 23 Fedora Update System 2008-12-21 03:38:05 EST
preupgrade-1.0.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11540
Comment 24 Fedora Update System 2008-12-21 03:45:25 EST
preupgrade-1.0.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11437
Comment 25 Jon Baker 2009-01-05 15:48:49 EST
Just ran preupgrade-cli 1.0.1-1.fc8 on one of my servers which required the disk image download.  I did get the network initialization error but when I hit retry it succeeded.  Not sure exactly why that happened other than this is a very old box and we've had problems with the network card initializing in even FC6.  But other than that, it worked perfectly.  Thanks for the fix!
Comment 26 Fedora Update System 2009-01-07 04:07:26 EST
preupgrade-1.0.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2009-01-07 04:08:10 EST
preupgrade-1.0.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2009-01-07 04:23:54 EST
preupgrade-1.0.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.