Bug 472935 - Lenovo T61 crash randomly [mi] EQ overflowing. The server is probably stuck in an infinite loop.
Lenovo T61 crash randomly [mi] EQ overflowing. The server is probably stuck i...
Status: CLOSED DUPLICATE of bug 464866
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
10
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 12:58 EST by Matias Kreder
Modified: 2009-09-06 05:29 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 05:29:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (93.99 KB, text/x-log)
2008-11-25 13:11 EST, Matias Kreder
no flags Details
here you can see the error (179.40 KB, text/plain)
2008-11-27 10:46 EST, Matias Kreder
no flags Details
xorg log of crash (133.77 KB, text/plain)
2008-11-28 20:56 EST, Zing
no flags Details
Xorg.0.log.error (91.52 KB, application/octet-stream)
2009-02-19 15:28 EST, Kyle Pablo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 444449 None None None Never
FreeDesktop.org 18640 None None None Never
Launchpad 259808 None None None Never
Launchpad 276518 None None None Never

  None (edit)
Description Matias Kreder 2008-11-25 12:58:14 EST
Description of problem:

This is a problem hard to reproduce, i experience this bug 3 days in a day. I open a lot of programs to work, thunderbird, seamonkey, firefox, and sometimes when i'm changing between this applications, i see a crash on the screen, i mean, i can move the mouse and click anywhere but nothings happens. 

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.5.3-5.fc10.x86_64
xorg-x11-drivers-7.3-9.fc10.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Install F10 x86_64 (pre realese in my case) on a T61
2. Update it! 
3. Use the GUI some hours
  
Actual results:

I logged into my computer from my workstations, and i run 'startx' in a console, when the bug explained before appears i see this backtrace:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4e7a26]
1: /usr/bin/X(mieqEnqueue+0x291) [0x4c8591]
2: /usr/bin/X(xf86PostMotionEventP+0xc4) [0x491494]
3: /usr/bin/X(xf86PostMotionEvent+0xa9) [0x491669]
4: /usr/lib64/xorg/modules/input//evdev_drv.so [0x7fb604306126]
5: /usr/bin/X [0x47a765]
6: /usr/bin/X [0x46b307]
7: /lib64/libc.so.6 [0x3f00a32f60]
8: /lib64/libc.so.6(ioctl+0x7) [0x3f00addff7]
9: /usr/lib64/libdrm.so.2 [0x3f12c03023]
10: /usr/lib64/libdrm.so.2(drmCommandWrite+0x1b) [0x3f12c032ab]
11: /usr/lib64/xorg/modules/drivers//intel_drv.so(I830Sync+0x118) [0x5b02d38]
12: /usr/lib64/xorg/modules//libexa.so(exaWaitSync+0x5c) [0x7fb6151a029c]
13: /usr/lib64/xorg/modules//libexa.so(ExaDoPrepareAccess+0x91) [0x7fb6151a1591]
14: /usr/lib64/xorg/modules//libexa.so [0x7fb6151a6749]
15: /usr/lib64/xorg/modules//libexa.so [0x7fb6151a6c7f]
16: /usr/lib64/xorg/modules//libexa.so(exaDoMigration+0x68f) [0x7fb6151a746f]
17: /usr/lib64/xorg/modules//libexa.so(exaCopyNtoN+0x3fd) [0x7fb6151a42bd]
18: /usr/lib64/xorg/modules//libexa.so(exaComposite+0x921) [0x7fb6151a95b1]
19: /usr/bin/X [0x5291b8]
20: /usr/lib64/xorg/modules//libexa.so [0x7fb6151a4f87]
21: /usr/lib64/xorg/modules//libexa.so(exaGlyphs+0x47a) [0x7fb6151a5ada]
22: /usr/bin/X [0x5294d1]
23: /usr/bin/X [0x51bc45]
24: /usr/bin/X(Dispatch+0x364) [0x4468d4]
25: /usr/bin/X(main+0x45d) [0x42cd1d]
26: /lib64/libc.so.6(__libc_start_main+0xe6) [0x3f00a1e546]
27: /usr/bin/X [0x42c0f9]
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
 
and so on..

Expected results:

Everything works properly. no crash

Additional info:
Comment 1 Matěj Cepl 2008-11-25 13:00:13 EST
I would love to get /var/log/Xorg.0.log just for sake of completness, but this looks pretty persuasive as it is.
Comment 2 Matias Kreder 2008-11-25 13:11:41 EST
Created attachment 324643 [details]
Xorg.0.log
Comment 3 Matias Kreder 2008-11-25 13:12:44 EST
The error is not displayed in this log file, if I see the error again, before start X i will save the log, if there is an error. Thanks
Comment 5 Kornienko Sergey 2008-11-26 18:12:33 EST
Hello all ! 
I have similar problem. I can login over ssh to my notebook.

Hardware: Samsung Q45, Intel GMA965
DE: KDE 4.1.3

Steps to Reproduce:
1. Update F9 to F10 x86 on a Samsung Q45
2. Use the GUI some hours or minutes

Content of my xorg.conf
# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Synaptics" "CorePointer"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "yes"
        Option      "TapButton1" "1"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "DRI"
        Mode 0666
EndSection


Content of my Xorg.0.log

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x812bc5b]
1: /usr/bin/X(mieqEnqueue+0x289) [0x810b379]
2: /usr/bin/X(xf86PostMotionEventP+0xc2) [0x80d4262]
3: /usr/bin/X(xf86PostMotionEvent+0x68) [0x80d43c8]
4: /usr/lib/xorg/modules/input//evdev_drv.so [0x388a8d]
5: /usr/bin/X [0x80bcdb7]
6: /usr/bin/X [0x80ac91e]
7: [0x110400]
8: [0x110416]
9: /lib/libc.so.6(ioctl+0x19) [0xad4949]
10: /usr/lib/libdrm.so.2 [0x442a6cf]
11: /usr/lib/libdrm.so.2(drmCommandWrite+0x34) [0x442a984]
12: /usr/lib/xorg/modules/drivers//intel_drv.so(I830Sync+0x135) [0x2f4ca5]
13: /usr/lib/xorg/modules/drivers//intel_drv.so [0x31e95a]
14: /usr/lib/xorg/modules//libexa.so(exaWaitSync+0x65) [0x1d3095]
15: /usr/lib/xorg/modules//libexa.so(ExaDoPrepareAccess+0x7e) [0x1d43ae]
16: /usr/lib/xorg/modules//libexa.so [0x1d93b2]
17: /usr/lib/xorg/modules//libexa.so [0x1d9905]
18: /usr/lib/xorg/modules//libexa.so(exaDoMigration+0x652) [0x1da0c2]
19: /usr/lib/xorg/modules//libexa.so [0x1dbae3]
20: /usr/lib/xorg/modules//libexa.so(exaComposite+0xd5a) [0x1dc92a]
21: /usr/bin/X [0x816f6fa]
22: /usr/bin/X(CompositePicture+0x19a) [0x815818a]
23: /usr/bin/X [0x815e055]
24: /usr/bin/X [0x815ad75]
25: /usr/bin/X(Dispatch+0x34f) [0x8085e9f]
26: /usr/bin/X(main+0x47d) [0x806b71d]
27: /lib/libc.so.6(__libc_start_main+0xe5) [0xa0f6d5]
28: /usr/bin/X [0x806ab01]
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
..................................................................
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop
Comment 6 Kornienko Sergey 2008-11-26 18:16:11 EST
Additional: I don't have any problem on my desktop PC with Athlon XP 2500+ and Nvidia GeForce FX 5200 with xorg-x11-drv-nvidia-173xx-173.14.15-2.fc10.i386 driver.
Comment 7 Matias Kreder 2008-11-27 10:46:49 EST
Created attachment 324895 [details]
here you can see the error

Here is the log with the bug
Comment 8 Matias Kreder 2008-11-28 09:22:03 EST
At the moment, i can see that disabling the Desktop Effects, the problem does not appear, I was testing it, yesterday and today. But I don't know if I'm safe...
Comment 9 Zing 2008-11-28 20:56:33 EST
Created attachment 325060 [details]
xorg log of crash

pretty much the same backtrace for me, but with an ati radeon x800. I can't seem to make it happen at will, but it's happened twice for me today.

xorg-x11-server-Xorg-1.5.3-5.fc10.x86_64
Comment 10 Khashayar Naderehvandi 2008-12-05 21:17:05 EST
I'm seeing this too on an intel 4500. Need to follow this bug.
Comment 11 Matias Kreder 2008-12-10 02:48:49 EST
any news with this?
Comment 12 Grégory SCHMITT 2008-12-11 05:18:59 EST
I thought I'd bring some comments on it. I have experienced the bug on one of my computers, running an NVidia video card, based on the 6600GT chip.

My findings are:
- bug will happen almost immediately after gdm login (need to wait about 30 secs for system to crash)
- bug will happen whether I'm using Fedora 10 stock kernel (2.6.27.5 + pathes) or a vanilla kernel (2.6.27.7)
- bug will happen wether XAA or EXA is enabled
- bug will happen with DRI disabled (I even went as far as deleting the libdri.so file to make sure it wouldn't be used)
- the only way I found to have a stable, crash-free system is to put option "NoAccel" to "on".

I'm also using another computer (laptop) with an ATI Radeon RV350 chip, with exact same software (kernel version, rpms packages) on it - never had a similar crash, XAA works fine, 3D acceleration works. It looks to me the bug is actually in X.org, and not in any of the graphics driver.
Comment 13 Grégory SCHMITT 2008-12-11 05:32:30 EST
Other thoughts:

- bug will happen with the "nv" or "nouveau" driver
- proprietary NVidia driver is not used or installed
- DRM support was activated in the kernel as a module, but no hardware module was compiled since there's no specific module for NVidia hardware
Comment 14 Eugene Savelov 2008-12-13 14:06:41 EST
I think was able to work around this by using nomodeset kernel parameter to disable kernel modesetting.
http://docs.fedoraproject.org/release-notes/f10/en_US/What_is_New_for_Installation_and_Live_Images.html#sn-GRUB
I have Dell Inspiron 1501 x86_64 fedora 10

Also configured xorg.conf by system-config-display
Comment 15 Grégory SCHMITT 2008-12-13 14:35:22 EST
This bug is unlikely to be related to kernel modesetting (KMS) since I run with the nomodeset parameter and that KMS code is not available in a vanilla kernel, although disabling nomodeset will improve stability (KMS is very early code, mostly untested) and will help isolate the issue.

Additional info
- bug has been reported for x86_64, but I am running x86_32.
- bug happened whether xorg.conf exists in /etc/X11 or not
- bug happened whether input devices were specified or not in xorg.conf
Comment 16 Grégory SCHMITT 2008-12-13 14:57:10 EST
Is https://bugzilla.redhat.com/show_bug.cgi?id=469292 a duplicate too?
Comment 17 Eugene Savelov 2008-12-14 01:13:11 EST
I agree that bug itself may be not directly related to KMS, but once I turned KMS off, kernel switched to non-framebuffer text mode, and radeon driver in xorg started working reliably. After applying all updates  I tried to go back to kernel modeset mode, but what I found xorg performance decreased a lot. So I think the bug is somehow performance-related.
Comment 18 Khashayar Naderehvandi 2008-12-14 06:35:39 EST
I wonder if we're not having a bunch of different bugs here. In my case, for example, I have no KMS kernel, and I _never_ hit the bug without running compiz. Especially the last point goes against some of the comments above.
Comment 19 Grégory SCHMITT 2008-12-14 13:05:45 EST
AFAIK, this bug behaves very differently from a computer to another.

So far, I can only assume a few things:
- the bug is not related to KMS, which is a completely different issue.
- the bug seems to be located in the X.org server, not the video drivers (bug happens with nvidia, radeon, intel cards).
- the bug can happen almost instantly (sometimes even crashing gdm after start) or after a few hours.
- desktop effects or OpenGL applications seem to be aggravating factors.
Comment 20 Kornienko Sergey 2008-12-16 12:45:53 EST
Hello all !
For me working this workaround from FreeDesktop.org, bugid: 18640, posted by Jim McDonough (thank you Jim ! :)): "switching from exa to xaa makes it go away."
I'm added option "Option "AccelMethod" "XAA"" to xorg.conf in section "Device"
and my notebook was working about two or three days without any problem and I can use desktop effects in KDE and my favourites OpenGL applications like Google Earth. glxgears show 1120 FPS.

In the same way, messages 
"
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
"
from my Xorg.0.log go away.

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
        Option      "AccelMethod" "XAA"
EndSection

I think the bug maybe in EXA with new acceleration subsystem 
GEM (Graphics Execution Manager), http://www.phoronix.com/scan.php?page=news_item&px=Njc4OQ , providing from Intel, if this code added by Fedora team in current kernel.
Comment 21 Grégory SCHMITT 2008-12-16 13:08:19 EST
Please read again my comments:
- XAA was used and bug happened anyway 
- kernel used was a vanilla kernel 2.6.27.7, not including any Fedora patch
- GEM will be integrated in 2.6.28 only

Not that I really care anyway, since I sold the computer yesterday...
Comment 22 Ronald Kuetemeier 2008-12-23 16:56:51 EST
For what it's worth. 
FC10:

(--) PCI:*(0@0:2:0) Intel Corporation Mobile 915GM/GMS/910GML Express Graphics C
ontroller rev 3, Mem @ 0xb0080000/0, 0xc0000000/0, 0xb0000000/0, I/O @ 0x0000180
0/0
(--) PCI: (0@0:2:1) Intel Corporation Mobile 915GM/GMS/910GML Express Graphics C
ontroller rev 3, Mem @ 0x6c000000/0

Crashed at least 1-2 times a day.

Used:
Option      "NoAccel" "on"


No crash so far during the last day.
Comment 23 Matías Kreder 2009-02-09 08:45:20 EST
do you guys have any news in this subject? any fix/workarround? i'm using:

        Option      "AccelMethod" "XAA"

without crashes but i've rendering problems, in some applications, and in the GDM menu.

thanks
Comment 24 Kyle Pablo 2009-02-19 15:28:50 EST
Created attachment 332635 [details]
Xorg.0.log.error

Hello, 

This bug is seriously affecting my computer. I have a Lenovo T400 w/ an  Intel
Graphics Media Accelerator 4500MHD. Kernel-2.6.27.12-170.2.5.fc10.x86_64 and
KDE 4.2.

My computer freezes rendering X useless.  The keyboard is dead but I can still
move the mouse around but cannot click anything or select anything. I had to
ssh into it to isolate the problem. I have to do a hard power off by holding
the power button down. My error log is attached.

Duplicate? https://bugzilla.redhat.com/show_bug.cgi?id=465884
Comment 25 Jakub Roztočil 2009-03-22 22:15:03 EDT
I have a Lenovo x41 and this bug occurs several times a day. The screen gets frozen and the only thing I can do is move the coursor. (I must say that this probably the most annoying bug I've experienced with Fedora since the version 3.)
Comment 26 Eric Donkersloot 2009-04-28 06:59:54 EDT
This sounds like a duplicate of bug 464866
Comment 27 Matías Kreder 2009-05-26 18:23:20 EDT
I'm having good luck with this workaround, I'd like that someone test it and confirm if it works or not. I'm running kernel 2.6.29.2-52.fc10.i686 from koji.

http://koji.fedoraproject.org/koji/buildinfo?buildID=99901

Could you please let me know if it works with this kernel? or I am just experiencing lucky. 

Also I remove compiz fusion and I have installed compiz 0.8.3 from this repo:

http://www.dfm.uninsubria.it/compiz/fusion/

please, let me know any news on this.
Comment 28 Kornienko Sergey 2009-06-15 07:09:09 EDT
Hello all !
I'm not sure at 100%, but seems to have helped me move to Fedora 11, kernel 2.6.29 and the driver from intel 2.7.0, as well as switching mode acceleration "UXA"
Comment 29 Vedran Miletić 2009-09-06 05:29:14 EDT
Duplicate per comment #26.

*** This bug has been marked as a duplicate of bug 464866 ***

Note You need to log in before you can comment on or make changes to this bug.