Bug 472940 - Need to warn users of problematic updates
Need to warn users of problematic updates
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 13:33 EST by Alex Hudson (Fedora Address)
Modified: 2009-01-14 08:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 08:29:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Hudson (Fedora Address) 2008-11-25 13:33:38 EST
Description of problem:

Some software doesn't like being updated while it's running: canonical examples for me are Firefox and Thunderbird (for probably the same technical reason), when with reasonable frequency updating to a newer version causes any existing running process to behave badly, for some new exciting type of "badly" each time - Firefox likes opening windows with no content, Tbird just lost a mail I was composing. I've also had similar issues with OOo, and something else I forgot - I imagine any app with plug-ins, or that calls out external apps, lazily loads dlls, etc. etc., is potentially in this category.

I realise that problem isn't a PackageKit bug per se. However, it would be nice to have some way in the UI to mitigate this issue - although I think it's clear that PK cannot solve this alone.

What I would like, as a user, is some kind of warning that some of my apps might go haywire if I'm running the update while they're open. What would be absolutely superb would be some way of having PK shut the app down, update it, and re-open it in previous state - though almost certainly quite difficult to accomplish.

Although more pop-up warnings aren't exactly wonderful, I would much prefer a dialog saying something like "I'm about to update Tbird. Because you have it open already, you need to shut it down before I start, otherwise you risk losing data".

Presumably this would need some kind of input from the packaging community about exactly what kind of data a package could provide to communicate this - a good start would just be a simple flag which says "I'm troublesome" and then PackageKit giving me a list of troublesome apps before updating (if there are any). Everything else would be extra gravy tbh.
Comment 1 Richard Hughes 2009-01-14 08:29:23 EST
commit 6cddc916fec235aa4e722ef685c5320230b80b06
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Oct 15 08:23:07 2008 +0100

    feature: add functionality to check for files being used that have been updated, and send a session restart required signal

:100644 100644 d206d43... 291f934... M	etc/PackageKit.conf.in
:100644 100644 d831734... ce94a1d... M	src/pk-post-trans.c
:100644 100644 de716e5... 3d1ff2a... M	src/pk-post-trans.h
:100644 100644 0b249c7... 4bb2ad4... M	src/pk-transaction.c

Note You need to log in before you can comment on or make changes to this bug.