This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 472943 - odd dependency behavior
odd dependency behavior
Status: CLOSED DUPLICATE of bug 223642
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 13:46 EST by seth vidal
Modified: 2013-07-28 21:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-28 12:24:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description seth vidal 2008-11-25 13:46:04 EST
Description of problem:
On a new f10 system with updates installed


rpm -e --test xorg-x11-filesystem; echo $?
0

rpm -e xorg-x11-filesystem; echo $?
0

rpm -Va --nofiles --nomd5

Unsatisfied dependencies for xorg-x11-font-utils-1:7.2-6.fc10.i386:
	xorg-x11-filesystem >= 0.99.2-3 is needed by xorg-x11-font-utils-1:7.2-6.fc10.i386
Unsatisfied dependencies for libX11-1.1.4-5.fc10.i386:
	xorg-x11-filesystem >= 0.99.2-3 is needed by libX11-1.1.4-5.fc10.i386


That seems odd to me. It causes some pain w/yum-remove-with-leaves plugin b/c it is seeing xorg-x11-filesystem as a leafnode when it is not. does it have to do w/the xorg-x11-filesystem pkg only being requires(pre)'d? or is this just a regular bug?

Version-Release number of selected component (if applicable):
rpm-4.6.0-0.rc1.7.i386
Comment 1 Panu Matilainen 2008-11-28 12:24:13 EST

*** This bug has been marked as a duplicate of bug 223642 ***

Note You need to log in before you can comment on or make changes to this bug.