Bug 472950 - RFE: Relax firewall rulecheck to accept either -J REJECT or -j DROP as final rule for ipv4/6?
RFE: Relax firewall rulecheck to accept either -J REJECT or -j DROP as final ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sectool (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Kopeček
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 14:16 EST by Valdis Kletnieks
Modified: 2009-01-07 04:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:30:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2008-11-25 14:16:50 EST
Description of problem:
Since the last line of the ruleset is:
[0:0] -A INPUT -j DROP
maybe sectool shouldn't complain with:
Custom IPv[46] "INPUT" chain is the last rul in INPUT chain with policy ACCEPT and doesn't contain REJECT rule which should be the last rule in chains with this policy.

It's still an open discussion if it's better to use -j REJECT (protocol proper, but allows an attacker to elicit responses), or -j DROP (make it harder to elicit response packets).

Version-Release number of selected component (if applicable):
sectool-0.9.1-3.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Kopeček 2008-11-27 05:22:26 EST
(In reply to comment #0)
> Description of problem:
> Since the last line of the ruleset is:
> [0:0] -A INPUT -j DROP
> maybe sectool shouldn't complain with:
> Custom IPv[46] "INPUT" chain is the last rul in INPUT chain with policy ACCEPT
> and doesn't contain REJECT rule which should be the last rule in chains with
> this policy.
> 
> It's still an open discussion if it's better to use -j REJECT (protocol proper,
> but allows an attacker to elicit responses), or -j DROP (make it harder to
> elicit response packets).

Thanks for feedback. I've fixed this in git.
Comment 2 Fedora Update System 2008-12-01 18:28:13 EST
sectool-0.9.2-2 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/sectool-0.9.2-2
Comment 3 Fedora Update System 2008-12-02 20:25:36 EST
sectool-0.9.2-2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sectool'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10649
Comment 4 Fedora Update System 2009-01-07 04:29:46 EST
sectool-0.9.2-2 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.