Bug 472953 - Java plugin fails when visiting an https site whose certificate is not in the trust path
Java plugin fails when visiting an https site whose certificate is not in the...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
: 473987 (view as bug list)
Depends On:
Blocks: 473565
  Show dependency treegraph
 
Reported: 2008-11-25 14:28 EST by Deepak Bhole
Modified: 2009-02-04 21:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 10:42:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Deepak Bhole 2008-11-25 14:28:50 EST
If a user visits a site whose certificate is not in cacerts, IcedTea Plugin encounters a fatal exception and exits.

The expected behaviour is that the user is prompted about the problem, and given a choice to add the certificate to cacerts.
Comment 1 Deepak Bhole 2009-01-21 15:31:57 EST
Just an update for those monitoring this issue.. it is now fixed upstream. The fix will be in the next Fedora release of OpenJDK.
Comment 2 Deepak Bhole 2009-01-22 13:53:09 EST
*** Bug 473987 has been marked as a duplicate of this bug. ***
Comment 3 Lillian Angel 2009-02-02 10:42:15 EST
this should be in rawhide within the next couple of days:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1098935
Comment 4 Fedora Update System 2009-02-04 21:23:32 EST
java-1.6.0-openjdk-1.6.0.0-9.b14.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.