Bug 472966 - Kickstart Distributions: Create/Edit page needs refinement
Kickstart Distributions: Create/Edit page needs refinement
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Partha Aji
Mike McCune
:
Depends On:
Blocks: space04 swcobbler
  Show dependency treegraph
 
Reported: 2008-11-25 15:41 EST by Mike McCune
Modified: 2012-03-06 03:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:06:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2008-11-25 15:41:17 EST
With the addition of cobbler support the Kickstart Distributions page needs some help.

* The External Location (url)*: field no longer has to be an external location.  This can also be a local path on the spacewalk server:

/opt/repo/f9-i386/

Need to update the labels to explain this.

* When creating the Distribution we have error conditions from cobbler:

# Can't find the kernel errors - Need to provide nice UI message stating it cant find the kernel at the path specified

# Make sure the input for the location is trimmed for preceding and trailing spaces

Feel free to add more to this bug as we work through this page.
Comment 1 Partha Aji 2009-01-15 12:36:51 EST
Text on this page needs to be worked on....
"The Kickstart RPM should be the name of the rpm containing the kickstart deploy scripts. These RPMs are provided by Spacewalk and located in the Spacewalk Tools child channels.
"
The need for KS rpm has been taken out now since all the auto kickstarts use spacewalk-koan...

Same with "The Tree Path, Kickstart RPM, Base Channel, and Installer Generation should always match. .....".. Remove the references to Kickstart RPM
Comment 2 Partha Aji 2009-01-15 12:40:12 EST
Ok this is really broken ... 
* When creating the Distribution we have error conditions from cobbler:

# Can't find the kernel errors - Need to provide nice UI message stating it
cant find the kernel at the path specified


All cobblery error conditions like missing kernel path/ iso path are NOT checked.. And the page just says "Distro Created" instead of showing the error...
Comment 3 Partha Aji 2009-03-15 03:44:16 EDT
should be resolved in the next iso
Comment 4 Miroslav Suchý 2009-09-17 03:06:38 EDT
Spacewalk 0.4 has been released for some time.

Note You need to log in before you can comment on or make changes to this bug.