Bug 472989 - 3ware 8006-2 LP raid card won't boot
3ware 8006-2 LP raid card won't boot
Status: CLOSED DUPLICATE of bug 466607
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 17:39 EST by Glen Gardner
Modified: 2008-12-30 15:56 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fedora 10 machine with 3ware 8006-2 LP raid card won't boot after installing.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-30 15:56:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Glen Gardner 2008-11-25 17:39:47 EST
Description of problem:

Fedora 10 machine x86_64 with 3ware 8006-2 LP raid card won't boot after installing.  Is the driver for this card gone missing from the kernel ????
Comment 1 Dave Jones 2008-11-25 18:29:45 EST
if the driver were missing, it wouldn't have managed to get through the install at all. (The installer and the final image use the same kernel).
It should be using the 3w-xxxx driver I think, which is definitly built in the rpm.

What might be failing however, is the initrd creation.  Peter?
Comment 2 Charlie Moschel 2008-11-26 09:40:30 EST
Yes, F10 initrd does not wait long enough for the disk scans to complete, with many scsi and raid cards.  3w-xxxx is confirmed to be a problem in bug #466071 comment #46, and has one workaround there too.  Boot a rescue shell, chroot, rebuild initrd with the scsi_wait_scan module, then reboot.

bug #466534 comment #20 has a list of the 10 or so other dupe bugs that have been accumulating for a while, if you want more details.
Comment 3 Hans de Goede 2008-12-15 04:53:44 EST
Hi all,

First of all apologies for not responding to this bug for so long, we've been
swamped with other stuff. We understand this is a rather critical bug.

We've prepared an mkinitrd image, which should fix the not waiting long enough issue. I've put detailed instructions on how to test this in bug 466607 comment 57.

Can you please test if this fixes the issues with 3w-xxxx cards?
Comment 4 Karl Auerbach 2008-12-30 12:48:44 EST
Rather than building a new initrd I simply updated my /boot/grub/grub.conf so that the parameter is provided to the kernel via its command line.  Here's an example:

title Fedora (2.6.27.9-159.fc10.x86_64)
    root (hd0,0)
    kernel /vmlinuz-2.6.27.9-159.fc10.x86_64 ro root=/dev/VolGroup00/RootLV rhgb quiet scsi_mod.scan=sync
    initrd /initrd-2.6.27.9-159.fc10.x86_64.img

Of course, I had to boot the rescue (or run Knoppix) to be able to edit my /boot/grub/grub.conf file.

This approach has the advantage that the additional parameter is carried forward by the kernel update process when a new kernel rpm comes out.

By the way, I'm running with a 3ware Inc 9650SE
Comment 5 Hans de Goede 2008-12-30 15:56:07 EST
Ok, so its the same issue, closing this is a dup of 466607 then.

*** This bug has been marked as a duplicate of bug 466607 ***

Note You need to log in before you can comment on or make changes to this bug.