Bug 473075 - RFE: update NetBeans to 6.5
RFE: update NetBeans to 6.5
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: netbeans (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Victor G. Vasilyev
Fedora Extras Quality Assurance
:
Depends On: 475058 479877 480001
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-26 09:14 EST by Chris
Modified: 2009-11-24 23:26 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-24 23:26:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris 2008-11-26 09:14:43 EST
Description of problem:
NetBeans 6.5 has been released [1]

[1] http://www.netbeans.org/community/releases/65/index.html
Comment 1 Victor G. Vasilyev 2008-12-10 12:35:37 EST
The task is already started ( http://wiki.netbeans.org/FedoraPackagingNB65 ) and the latest version of the NetBeans will be packaged.

NetBeans 6.5 relies on new version of the platform that should be before included into Fedora. See Bug #475058 - Review Request: netbeans-platform9 - NetBeans 6.5 Platform 9.
Comment 2 Pierre-YvesChibon 2009-01-15 03:30:43 EST
Do we have any ETA for NetBeans 6.5 ?

Thanks
Comment 3 Victor G. Vasilyev 2009-01-15 07:15:33 EST
Pessimistic Estimated Time of Arrival for the NetBeans 6.5 is the next week.
Comment 4 Victor G. Vasilyev 2009-01-16 13:02:45 EST
The task is completed. First release of the NetBeans 6.5 packages in Fedora!

Successful koji build: http://koji.fedoraproject.org/koji/taskinfo?taskID=1058945

Changes in the netbeans-6.5-1 package for fc11:
- Bootstrapping of the spec for IDE of the NetBeans 6.5
- Removing of all binaries-list files
- New dependency on jakarta-oro-2.0.8.jar is added
- The Distribution tag is removed
- jsch 0.1.24 -> 0.1.39
- lucene 2.2.0 -> 2.3.1 (2.3.2)
- netbeans-javaparser 6.1 -> 6.5
- junit4 4.1 -> 4.5
- netbeans-platform9 -> netbeans-platform
- netbeans-platform9-harness -> netbeans-platform-harness
- BR netbeans-platform-harness
- svnClientAdapter 0.9.23 -> 1.4.0
- B(R) subversion-javahl >= 1.5.0
- Creation of the .noautoupdate files is  moved to the install section

Please, visit http://www.netbeans.org/ site for more info about the NetBeans 6.5.

A bug in the package?
https://admin.fedoraproject.org/pkgdb/packages/bugs/netbeans
Discussion about the package: linux-packaging@installer.netbeans.org
Please, use a secret address :-) victor.vasilyev@sun.com for hot issues.

A bug in the IDE?
http://www.netbeans.org/community/issues.html
Generic discussion about the IDE: nbusers@netbeans.org
NetBeans Mailing Lists and Forums: http://www.netbeans.org/community/lists/

Welcome to test and use it!
Comment 5 Nicholas Wourms 2009-01-16 21:30:55 EST
Please fix the OpenJDK build to use the new netbeans platform package naming and respin it for f11.
Comment 6 Lillian Angel 2009-01-19 10:04:25 EST
$ sudo rpm -Uvh netbeans-6.5-1.fc11.noarch.rpm netbeans-6.5-1.fc11.src.rpm netbeans-ide10-6.5-1.fc11.noarch.rpm netbeans-java2-6.5-1.fc11.noarch.rpm netbeans-apisupport1-6.5-1.fc11.noarch.rpm
error: Failed dependencies:
	netbeans-svnclientadapter >= 6.5 is needed by netbeans-ide10-6.5-1.fc11.noarch
	netbeans-javaparser = 6.5 is needed by netbeans-java2-6.5-1.fc11.noarch
Comment 7 Victor G. Vasilyev 2009-01-19 10:57:07 EST
Both netbeans-javaparser-6.5-1.fc11.noarch.rpm and  netbeans-svnclientadapter-6.5-1.fc11.noarch.rpm in rawhide repo.
They need to be upgraded up to 6.5 version.
Comment 8 Chris 2009-01-19 16:58:22 EST
Will there be an update to F10?
Comment 9 Victor G. Vasilyev 2009-01-20 08:46:15 EST
An update for F10 is in our plans, but some issues with dependencies on other packages need to be resolved before according to Fedora requirements.
Currently, it is under investigation.
Comment 10 Nicholas Wourms 2009-01-21 14:13:49 EST
When will OpenJDK be respun with the correct requires? Netbeans is not installable if you have the openjdk -devel package installed.
Comment 11 Lillian Angel 2009-01-21 14:18:14 EST
yes it will, by the end of next week it will be in rawhide.
Comment 12 Pierre-YvesChibon 2009-03-24 04:56:31 EDT
What are the news regarding F10 ?
Comment 13 Thomas Moschny 2009-04-07 09:54:45 EDT
Am I only to blind to find it, or are there no plugins for NetBeans in Fedora, providing language support other than for Java  (PHP, Groovy, etc.), neither in F10 nor in rawhide?
Comment 14 Victor G. Vasilyev 2009-04-07 17:00:04 EDT
Only basic modules of the NetBeans IDE are provided by the netbeans.org community for the Linux distributions.
A cause is a number of dependencies on external projects that are not packaged for Linux yet. 

BTW. you would help to community by participating in packaging of the required projects. http://fedoraproject.org/wiki/PackageMaintainers/Join

In the current situation, please use NetBeans Update Centers to install required plugins: NetBeans Main Menu/Tools/Plugins/Avalaible Plugins.
Note, NetBeans installed from RPMs has a special configuration of Update Centers that is adopted for Fedora ( see NetBeans Main Menu/Tools/Plugins/Settings )
Comment 15 Chris 2009-06-12 11:08:24 EDT
Netbeans 6.5 works flawlessly with F11 now. I do not know if there are still plans to backport the changes to F10 but afaiac this one can be closed...
Comment 16 Bug Zapper 2009-11-18 03:58:20 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Victor G. Vasilyev 2009-11-24 23:26:33 EST
This is old unclosed bug that doesn't require any actions.
I'll close it as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.