Bug 473083 - Ekiga no-longer has a network configuration page
Ekiga no-longer has a network configuration page
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ekiga (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-26 09:53 EST by Steve Hill
Modified: 2008-11-26 14:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 14:33:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 562352 None None None Never

  None (edit)
Description Steve Hill 2008-11-26 09:53:33 EST
Description of problem:
There is no network configuration page in the Ekiga preferences any more.  This means that you cannot turn off STUN, making Ekiga *completely unusable* in many network configurations.

Version-Release number of selected component (if applicable):
ekiga-3.0.1-2.fc10.i386

Actual results:
If the SIP client and the SIP server you are connecting to are both on the internal side of a NAT, you must turn off STUN or the client will present the wrong IP address to the server.  Ekiga used to allow the user to configure STUN and choose which NIC to bind to - these options now appear to have been completely removed from the preferences screen.

Expected results:
The preferences screen should actually contain the preferences needed to configure the application.

Additional info:
No doubt this is another victim of the Gnome project's propensity for removing configuration options "in case they confuse people".  These network options are not irrelevant things that might confuse people, they are things which the user *HAS* to configure correctly or the software just plain won't work at all.  Making bad assumptions about a user's network configuration with no way for the user to override them is a really bad move - it makes what was a very good piece of software completely non-functional.

It should be noted that this is not an unusual network configuration - this is exactly how almost everyone with a local SIP server is going to set it up.
Comment 1 Peter Robinson 2008-11-26 14:33:18 EST
I've reported this upstream and am closing this bug report because its an upstream issue as opposed to a direct Fedora issue and hence will get more attention there.

http://bugzilla.gnome.org/show_bug.cgi?id=562352

Note You need to log in before you can comment on or make changes to this bug.