Bug 473092 - system hangs after upgrade FC9>FC10
system hangs after upgrade FC9>FC10
Status: CLOSED DUPLICATE of bug 470628
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-26 10:08 EST by Jacques Rodary
Modified: 2008-12-10 15:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 15:28:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacques Rodary 2008-11-26 10:08:12 EST
Description of problem: after upgrading from feedora 9 to 10, the system hangs after this error: mounting /dev/root on /sysroot as ext3: No such file or directory.
Besides, the swap partition isn't mounted (unable to resume device (UUID=....)


Version-Release number of selected component (if applicable):


How reproducible:always


Steps to Reproduce:
1.boot
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Jones 2008-11-26 15:07:35 EST
this is nearly always a broken initrd.  What kind of disk controller is the root filesystem on?
Comment 2 Jacques Rodary 2008-11-27 00:05:50 EST
SCSI controller- LSI 53C 1010 R 64-bit/66MHz
Comment 3 Jacques Rodary 2008-11-27 00:18:57 EST
and  the SCSI BIOS is Symbios SDMS version 4.0
Comment 4 Tim Fenn 2008-12-03 22:27:17 EST
Try booting to rescue mode, chrooting to the sysimage and running:

mkinitrd -v -f --with=scsi_wait_scan /boot/initrd-2.6.27.5-117.fc10.x86_64.img
2.6.27.5-117.fc10.x86_64

(or substitute i686 for x86_64 if necessary)

potentially a dupe of:

https://bugzilla.redhat.com/show_bug.cgi?id=429937
Comment 5 Jacques Rodary 2008-12-04 18:53:37 EST
     Thanks. Everything is OK
Comment 6 Jacques Rodary 2008-12-09 18:44:00 EST
New kernel 2.6.27.7-134.fc10 still has the same issue, with the same solution: mkinitrd -v -f --with=scsi_wait_scan /boot/initrd-2.6.27....
Comment 7 Dave Jones 2008-12-10 15:28:28 EST

*** This bug has been marked as a duplicate of bug 470628 ***

Note You need to log in before you can comment on or make changes to this bug.