Bug 473123 - Upgrade system via Applet 3.0.9 fails
Upgrade system via Applet 3.0.9 fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-26 11:25 EST by aart van erven
Modified: 2014-01-21 18:07 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 07:20:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenhot of failed install (54.03 KB, image/jpeg)
2008-11-26 11:25 EST, aart van erven
no flags Details

  None (edit)
Description aart van erven 2008-11-26 11:25:37 EST
Created attachment 324755 [details]
screenhot of failed install

Description of problem:
Upgrade system via Applet 3.0.9 fails


Version-Release number of selected component (if applicable):3.0.9


How reproducible: Update system via internet after installation


Steps to Reproduce:
1.
2.
3.
  
Actual results:
ERROR with rpm_check_debug vs depsolve:
leafnode conflicts with suck-4.3.2-23.fc10.x86_64


Expected results:


Additional info:
Comment 1 Panu Matilainen 2008-11-28 12:21:05 EST
Rpm is just the messenger here... rpm_check_debug test in yum failing suggests that yum depsolve got something wrong (failed to notice a conflict in this case I suppose).
Comment 2 James Antill 2008-12-01 12:13:05 EST
Doing "yum install suck leafnode" from the cmd line wfm. Failing with:

--> Finished Dependency Resolution
suck-4.3.2-23.fc10.x86_64 from rawhide has depsolving problems
  --> suck conflicts with leafnode
Error: suck conflicts with leafnode
Comment 3 Richard Hughes 2008-12-02 03:40:57 EST
wtf? Why assign to PackageKit? not a yum bug != PackageKit...
Comment 4 James Antill 2008-12-02 10:20:33 EST
Did you look at the BZ? The screenshot pretty clearly indicates PK as the UI, and given that yum cmd line works ... I'm not sure what you expect me to do with it.
Comment 5 Richard Hughes 2008-12-02 10:42:01 EST
(In reply to comment #1)
> Rpm is just the messenger here... rpm_check_debug test in yum failing suggests
> that yum depsolve got something wrong (failed to notice a conflict in this case
> I suppose).

PK doesn't do depsolving, yum does. I'm just doing txmbr = self.yumbase.update and then running the transaction.
Comment 6 Tim Lauridsen 2008-12-04 05:16:23 EST
$ pkcon install suck leafnode
Error: transaction-error : suck conflicts with leafnode

So pkcon behaves just like yum-cli, more info about the user system is needed to detect where the problem is triggered.

rpm -q suck leafnode

yum --version

the output from 'yum update', so we can see what packages is in play when the error occurs.

Richard: i agree with James, this is bug should stay with pk, if it cant be reproduced with yum-cli, we must do the prober investigation and collect information before kicking it over to yum. In all cases with pk update problems a 'yum update' should be performed, to document what packages is being updated and to see if we get the same errors.
Comment 7 Richard Hughes 2009-01-14 08:30:14 EST
Does this issue still happen?
Comment 8 iarly selbir 2009-03-02 19:42:32 EST
Reporter, please, do you have some feedback about bug? is it solved?

thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 aart van erven 2009-03-05 12:08:12 EST
Yes, it seems solved, as neither leafnode nor suck seem to appear in the update list anymore when reviewing the update list. Thank you for your assistance,
regards,

Note You need to log in before you can comment on or make changes to this bug.