Bug 473153 - ens1371: ALSA woke us up to write new data to the device, but there was actually nothing to write!
ens1371: ALSA woke us up to write new data to the device, but there was actua...
Status: CLOSED DUPLICATE of bug 475236
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-26 15:17 EST by Jeff Bastian
Modified: 2009-03-02 20:37 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 20:37:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info.sh output (14.11 KB, text/plain)
2008-12-03 10:17 EST, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2008-11-26 15:17:01 EST
Description of problem:
I just installed Fedora 10 i386 under VMware Fusion 2.0 with VMI enabled.  Sound does not work at all; I just hear weird static from the speakers when I try to play any audio.

I noticed the messages below repeating very rapidly in /var/log/messages; just today I've had 235145 messages and counting!


Nov 26 13:34:20 scorpion pulseaudio[2912]: module-alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write! Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers.
Nov 26 13:34:22 scorpion pulseaudio[2912]: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 337920 bytes (1915 ms) Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers.
Nov 26 14:03:10 scorpion pulseaudio[2912]: module-alsa-sink.c: Increasing wakeup watermark to 368.53 ms


The first message ("nothing to write") is most frequent at 230423 entries so far today.  The second message ("exceptionally large") I've seen 2132 times.  And the third ("wakeup watermark") is 2573.

On the 2nd and 3rd messages, the values for bytes and ms vary with each message.

Version-Release number of selected component (if applicable):
kernel-2.6.27.5-117.fc10.i686
pulseaudio-0.9.13-6.fc10.i386

How reproducible:
Every time

Steps to Reproduce:
1. Install F10 under VMware Fusion 2.0
2. Try to play sound
  
Actual results:
Just hear static from speakers, and /var/log/messages is filling up with errors

Expected results:
Audio works, no errors in /var/log/messages

Additional info:
/etc/modprobe.conf is empty, but the following modules are loaded:
snd_ens1371            24196  3
gameport               13452  1 snd_ens1371
snd_rawmidi            22528  1 snd_ens1371
snd_ac97_codec         95264  1 snd_ens1371
ac97_bus                5504  1 snd_ac97_codec
snd_seq_dummy           6660  0
snd_seq_oss            30364  0
snd_seq_midi_event      9600  1 snd_seq_oss
snd_seq                48576  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10124  4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42496  0
snd_mixer_oss          16896  1 snd_pcm_oss
snd_pcm                65924  3 snd_ens1371,snd_ac97_codec,snd_pcm_oss
snd_timer              22024  2 snd_seq,snd_pcm
snd                    50616  17 snd_ens1371,snd_rawmidi,snd_ac97_codec,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9416  1 snd
snd_page_alloc         11016  1 snd_pcm


lspci reports
02:02.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 02)


VMware Tools are not installed
Comment 1 Jeff Bastian 2008-12-03 10:17:44 EST
Created attachment 325545 [details]
alsa-info.sh output
Comment 2 Jeff Bastian 2008-12-04 10:19:20 EST
I just tried disabling Glitch Free Audio as described on
  http://fedoraproject.org/wiki/Features/GlitchFreeAudio

I.E., I edited /etc/pulse/default.pa and added the tsched parameter:
  load-module module-hal-detect tsched=0

After rebooting, the audio works on my system; I can listen to music and play  YouTube videos again.

I am, however, still getting thousands of these errors in /var/log/messages:
Dec  4 09:14:08 scorpion pulseaudio[3020]: module-alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write! Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers.
Comment 3 Lennart Poettering 2008-12-08 13:27:32 EST
The ens1371 is borked. It signals "writability" on the audio fd, but there is actually nothing to write when we ask with snd_pcm_update_avail(). It's an ALSA bug. Reassigning.
Comment 4 Lennart Poettering 2009-03-02 20:37:33 EST

*** This bug has been marked as a duplicate of bug 475236 ***

Note You need to log in before you can comment on or make changes to this bug.