Bug 473158 - Failure when creating virtual machine
Failure when creating virtual machine
Status: CLOSED DUPLICATE of bug 453491
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-26 15:33 EST by Russell Doty
Modified: 2008-12-01 16:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 16:51:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russell Doty 2008-11-26 15:33:18 EST
Description of problem:

Creation of virtual machine fails with error "Unable to complete install: 'internal error Timed out while reading monitor startup output'". 


Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1. Run GUI to create a new virtual machine.
2. Enter choices (have tried several different choices with same results)
3. Select finish
  
Actual results:

Unable to complete install: 'internal error Timed out while reading monitor startup output'


Unable to complete install '<class 'libvirt.libvirtError'> internal error Timed out while reading monitor startup output
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 723, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 732, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 767, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 892, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Timed out while reading monitor startup output
'

Expected results:

Creation of virtual machine.

Additional info:

Fresh install of released F10 with latest updates. Phenom 9600 (Barcelona) processor. After closing error box, selecting "Finish" again will successfully create the new virtual machine.
Comment 1 Cole Robinson 2008-12-01 15:15:08 EST
A few questions:

- Does this reproduce reliably?
- Are you creating and fully allocating a disk via virt-manager? (basically default disk choices). How large?

Also, can you attach ~/.virt-manager/virt-manager.log?
Comment 2 Russell Doty 2008-12-01 15:43:01 EST
- Yes, this reproduces reliably for me.

- Yes, I'm creating and allocating a disk by virt-manager. I have seen the same behavior with both fully allocated and on-demand virtual disks. Disk sizes range from 4GB to 8GB.

I'll see about attaching the log when I get back to the system.
Comment 3 Cole Robinson 2008-12-01 16:51:15 EST
Okay, I think I know what the problem is. Duping this bug to the bug that's been open the longest on this issue.

*** This bug has been marked as a duplicate of bug 453491 ***

Note You need to log in before you can comment on or make changes to this bug.