Bug 473179 - Poor performance on GMA950 (tiling)
Poor performance on GMA950 (tiling)
Status: CLOSED DUPLICATE of bug 444328
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-26 18:03 EST by Daniel Mircea
Modified: 2009-09-21 10:42 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-21 10:42:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg log (100.50 KB, text/plain)
2008-11-26 18:03 EST, Daniel Mircea
no flags Details

  None (edit)
Description Daniel Mircea 2008-11-26 18:03:27 EST
Created attachment 324810 [details]
Xorg log

Description of problem:
Video performance is terrible after installing Fedora 10. I used to have about 1200 fps in glxgears in Fedora 9, however now I got ~ 300. Direct rendering works, but overall anything opengl is unusable (ex. compiz), because it's just too slow.

Version-Release number of selected component (if applicable):
Intel (Experimental Modsetting Driver)

How reproducible:

Steps to Reproduce:
1.Install Fedora 10 x86_64
2.Enable desktop effects
3.Open a few windows and move the cursor to the upper right corner to trigger the rearranging animation
  
Actual results:
The windows will move sluggish, causing frame skipping during the transition.
CPU usage stays close to 0.

Expected results:
CPU usually goes up, but just a for a brief moment while the transition is happening. The animation should had been smooth.

Additional info:
I'm attaching my xorg log. After examining it I found this thread which seemed to mentione my problem. 
http://thread.gmane.org/gmane.comp.freedesktop.xorg/
Comment 1 Jonathan Steffan 2008-12-05 16:38:59 EST
I also have this issue. I was able to play urbanterror with my device. Now I can barely use compiz.

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 2 Jonathan Steffan 2008-12-05 18:44:17 EST
I also max out ~300FPS even with nomodeset.
Comment 3 Ravindra Singh 2008-12-10 13:54:52 EST
Same here... I have a i945GM chipset i.e. GMA 950 card.

OpenGL performance is horrific and todays updates didn't work.

glxgears gives ~270 FPS compared to 1300 FPS in Ubuntu which I used before.

Compiz is running extremely slow so I am using GNOME's inbuilt compositing for basic shadow effects to have a nice looking desktop at least. Cant wait for the fix and get back to Compiz Fusion.
Comment 4 soosk_syah 2008-12-12 06:12:14 EST
I have exactly the same problem with the same chipset and driver since I upgraded to Fedora 10. I got 300FPS by glxgears which makes, e.g., compiz-fusion completely useless.
Comment 5 Dan Emmons 2008-12-19 00:09:12 EST
this sounds very similar to the problems i'm having on any eeePC 701 i install fedora 10 on - direct rendering is on, but no matter what settings i change, all opengl is slow - glxgears, for example, averages at 142fps. even weirder, enabling compiz doesn't change the glxgears performance at all - although compiz itself is unusably slow. so if we're dealing with the same bug on my machine and the OP's, the scope widens quite a bit. mine is equipped with an i915 card and it's 32-bit.
Comment 6 Jonathan Steffan 2008-12-23 18:32:21 EST
Adding the following option allows me to actually play video games again and fixes performance issues with compiz:

Section "Device"
	Identifier  "Videocard0"
	Driver      "intel"
        Option	    "Tiling" "False"
EndSection
Comment 7 Daniel Mircea 2008-12-23 19:31:32 EST
Thank you! Adding that option solved it.
Comment 8 Jonathan Steffan 2008-12-26 16:47:11 EST
I've noticed some stability issues with this option disabled. Mainly it seems to lock up when using a lot of memory with 3D intensive stuff (like playing video games.) It seems the issue is logged, and the device option is just a workaround:

(II) intel(0): Attempting memory allocation with tiled buffers.
(EE) intel(0): Failed to set tiling on front buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on back buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on depth buffer: rejected by kernel
Comment 9 Bojan Smojver 2008-12-26 19:44:54 EST
Indeed disabling tiling works around the problem. However, isn't tiling actually essential for really good performance?
Comment 10 Ravindra Singh 2009-01-13 05:16:43 EST
Ok... I added the tiling option and YES it did make a difference... I get a 700 on GLXGEARS instead of 250 and Compiz Fusion is running without LAG.

Its good till it lasts but I seriously would like this issue to be fixed!
Comment 11 Dan Emmons 2009-01-16 00:29:23 EST
I can echo what others are saying about the tiling option. This got my performance back where I expected it to be. I am looking forward to the improvements I have been reading about in the coming year, but for now, this will do. Maybe this should be considered in an update as a default setting for intel 915/945 cards?
Comment 12 Jonathan Steffan 2009-01-29 22:22:07 EST
This issue is still present with the 2.6.27.12-170.2.5 kernel and xorg-x11-drv-i810-2.5.0-4
Comment 13 Daniel Mircea 2009-04-01 07:08:02 EDT
The regression is still present on Fedora 11 Beta.
Comment 14 T. ONAY 2009-04-14 03:21:01 EDT
Same performance problem here on Fed10

Adding this 

Option     "Tiling" "False"

to xorg.conf solve the perf issue but add some weird behavior in compiz.
When i use the scale plugin of compiz the "scaled" windows are blinking, badly rendered, their contents are mixed ....

Device :

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 15 adriano 2009-05-05 10:41:17 EDT
I've upgraded my laptop DELL D620 to fedora 11 preview:
(Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27A2])

glxgears output:

1096 frames in 5.0 seconds = 219.075 FPS (compiz)

1343 frames in 5.0 seconds = 268.539 FPS (metacity)

The regression is still present. I'm very disappointed. 

Remember that Ubuntu is a rocket...
Comment 16 Philipp Bieber 2009-05-29 05:31:58 EDT
I'm using Fedora 11 32 Bit on a DELL Insiron e1405 / 640m.
My glx performance is consistent with that of the posters above.
Is there anything I can try or any further information I can add?

Device:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 17 Daniel Mircea 2009-06-30 15:06:05 EDT
I recently upgraded to Fedora 11 and the performance regression is gone. I get roughly 750 fps with glxgears.
Although this is still less than before the system feels just as snappy (this seems like an accurate explanation: http://qa-rockstar.livejournal.com/7869.html).
Note, that if tiling is disabled as suggested earlier, will impair performance rather than helping.
Comment 18 Jeff Bastian 2009-06-30 16:25:05 EDT
(In reply to comment #17)
> I recently upgraded to Fedora 11 and the performance regression is gone.


Not on my system (Lenovo T60 with 945GM/GMS).  With no xorg.conf, I get about 450 fps with glxgears.  If I create an xorg.conf with
        Option      "Tiling" "false"
        Option      "AccelMethod" "EXA"
then it jumps up to 600 fps.
Comment 19 Jeff Bastian 2009-06-30 16:41:08 EDT
Since glxgears is a bad test (see URL in comment 17), here are some new numbers for comparison:

tiling disabled in xorg.conf
  1. /usr/libexec/xscreensaver/glblur -fps          34 fps
  2. /usr/libexec/xscreensaver/sierpinski3d -fps    18-43 fps
  3. /usr/bin/teapot                                54 fps

tiling enabled (no xorg.conf)
  1. /usr/libexec/xscreensaver/glblur -fps          3 fps
  2. /usr/libexec/xscreensaver/sierpinski3d -fps    17-32 fps
  3. /usr/bin/teapot                                20 fps


So, disabling tiling definitely helps performance on my system.  In fact, with the glblur test with tiling enabled, I could barely move the mouse to stop glblur since glblur was hogging all the CPU.
Comment 20 Vedran Miletić 2009-09-21 10:42:32 EDT

*** This bug has been marked as a duplicate of bug 444328 ***
Comment 21 Vedran Miletić 2009-09-21 10:42:52 EDT
This is likely a duplicate, just different chipset.

Note You need to log in before you can comment on or make changes to this bug.