Bug 47321 - up2date unable to read packages on the RedHat server
up2date unable to read packages on the RedHat server
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-04 14:25 EDT by jcmain
Modified: 2015-01-07 18:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-04 14:25:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jcmain 2001-07-04 14:25:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16 i686)

Description of problem:
When running up2date from the command line as root, the application starts,
but has an error retrieving the list of available packages.


How reproducible:
Always

Steps to Reproduce:
1. Run up2date as root
2. Click on Connect

	

Actual Results:  When running up2date from the command line as root, the
window comes up as expected, and gives the following status in the status
bar: 

Retrieving package list...
Determining which packages are relevant...
Building web page...

But, when Netscape comes up is says:
STATE=Could not read data directory (/ftp/pub/up2date/rhl-6.2/i386/) ERROR:
A fatal error has occured. A small explanation is provided
below: The Server configuration points to a package directory that can not
be accessed at this time. 

Expected Results:  I expected to see a list of available packages in
Netscape.

Additional info:

I have tried this on two RedHat 6.2 machines, one was upgraded from 4.2 and
5.2 and the other was a fresh install of 6.2.

I am using an HTTP proxy, and have a firewall in place. But, I see no
evidence in the logs that the firewall is blocking any traffic for up2date.

Also, I tried updating up2date manually, but there seemed to be a long list
of dependencies.
Comment 1 Jay Turner 2001-07-05 10:34:10 EDT
If you are getting a message about "building the web page" then you are running
the old version of up2date which is no longer valid.  Up2Date has been
integrated into Red Hat Network and has a ton of added functionality now.  You
should head out to your favorite updates site and grab the new up2date and
rhn_register packages, register your machine and start taking advantage of the
new up2date features.  Take a look at this page for more information about using
the new up2date with RHL 6.2  . . .
http://www.redhat.com/network/service/rhl_62.html
Comment 2 jcmain 2001-07-12 17:50:59 EDT
Hello,

I downloaded the files on the web page and executed rpm -Uvh *.rpm, but got the
following error:

error: failed dependencies:
        libdb-3.1.so is needed by rpm-4.0.2-6x
        libdb-3.1.so is needed by rpm-python-4.0.2-6x
        rpm = 3.0.5 is needed by rpm-build-3.0.5-9.6x
        rpm = 3.0.5 is needed by rpm-devel-3.0.5-9.6x

I don't have libdb installed at all. In which package does it reside? Also,
should I just force the install of rpm-4.0.2 over rpm-3.0.5, or will that cause
other problems?

Sorry for the delay in responding, I did not receive any update e-mails, so I
didn't check bugzilla for updates. 

Thanks,
jcmain
Comment 3 Jay Turner 2001-07-13 07:05:37 EDT
Well, looks like I pointed you to a page that did not have all of its parts. 
You are going to want to download the db3 package as well.  This is a new
package which is needed by RPM, hence that reason you don't have it on your
system already.

In addition, after downloading and installing these packages, you are going to
want to run 'rpm --updatedb' to rebuild your database.  This is necessary due to
the change in RPM versions.
Comment 4 jcmain 2001-07-16 11:35:52 EDT
Hello,

That did the trick. 

FYI, I also had to download and install rpm-build-4.0.2-6x.i386.rpm and
rpm-devel-4.0.2-6x.i386.rpm. Also, I had to run 'rpm --rebuilddb'.

Thanks for you help with this.

Note You need to log in before you can comment on or make changes to this bug.