Bug 47323 - MATLAB 5.3 floating point exception on startup unless ROOT
Summary: MATLAB 5.3 floating point exception on startup unless ROOT
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-04 18:59 UTC by pdenis2
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-04 18:59:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description pdenis2 2001-07-04 18:59:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
 MATLAB 5.3 (SR_11) startup aborts with (MATLAB) floating point exception
unless user is root.  ***OK under Gnome***

How reproducible:
Always

Steps to Reproduce:
1.From KDE desktop -- Open konsole window (or xterm...)	
2. *As ordinary user* type: matlab
3.
	

Actual Results:  Matlab starts (opening comments + splash screen) then
aborts with:
------------------------------------------------------------------------
      Floating point exception detected at Wed Jul  4 18:42:24 2001
------------------------------------------------------------------------

Configuration:
  MATLAB Version:   5.3.0.14912a (R11)
  Operating System: Linux 2.4.2-2 #1 Sun Apr 8 20:41:30 EDT 2001 i686
  Window System:    The XFree86 Project, Inc (4003), display :0.0
  Current Visual:   0x21 (class 4, depth 24)
---------
[8 MBcore dumped]

Expected Results:  Matlab

Additional info:

Matlab launches OK if I su root, but I haven't tried using it much that way
(won't).  Since this machine/installation of MATLAB works fine under Gnome
desktop it looks like a KDE problem.  Will also copy The Mathworks.

HW: Athlon 1.2 GHz, Asus K7V, 256 MB RAM/512 Swap
OS:  2.4.2-2 #1 Sun Apr 8 20:41:30 EDT 2001 i686 unknown
 (RH 7.1 with all current upgrades except kernel*rpm)
video=Nvidia GeForce2; same behavior with XFree or NVIDIA drivers

Comment 1 Bernhard Rosenkraenzer 2001-07-05 13:30:23 UTC
Matlab must be doing something odd then - guess they're making some 
assumptions about the root window which don't match what kdesktop/kwin provide.

Since we don't have their source (not even the binaries actually), there is 
little we can do to find a workaround.



Note You need to log in before you can comment on or make changes to this bug.