Bug 473233 - Some function keys aren't working in F10 on Asus F3Sc anymore.
Some function keys aren't working in F10 on Asus F3Sc anymore.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 04:14 EST by Adrian "Adi1981" P.
Modified: 2009-12-18 01:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:58:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adrian "Adi1981" P. 2008-11-27 04:14:53 EST
Description of problem:
Fn+Fx keys doesn't work anymore on Asus F3Sc laptop with F10, even when they was working perfectly with F9. Those keys are
Fn+F1 - suspend (acpi event button/sleep SLPB 00000080)
Fn+F5 - brightness down (video LCDD 00000087)
Fn+F6 - brightness up (video LCDD 00000086)
Fn+F8 - LCD/CRT switch display (hotkey ATKD 00000061)

Only 2 which are still working, are Fn+F2 (wlan/bluetooth) and Fn+F7 (LCD on/off)

Version-Release number of selected component (if applicable):
$ rpm -q hal kernel acpid xorg-x11-server-Xorg
hal-0.5.12-12.20081027git.fc10.i386
kernel-2.6.27.5-117.fc10.i686
acpid-1.0.6-9.fc10.i386
xorg-x11-server-Xorg-1.5.3-5.fc10.i386

Steps to Reproduce:
1. Install F10 on asus f3sc
Comment 1 John Koelndorfer 2009-04-20 19:49:09 EDT
This was also a problem for me on my F10 laptop (Asus M50VM-A1), though I hadn't tried with a previous version of Fedora to see if it was better. Specifically, my media player keys (play/pause, stop, next, previous) didn't work. Brightness and volume worked for me. I am willing to help troubleshoot this bug if someone will take it on.
Comment 2 Adrian "Adi1981" P. 2009-04-21 09:29:23 EDT
For media and other Fn keys you can create a simple bash script, which will allow you to use them. Take a look into the scripts I'm using, and customize them to fit your needs and laptop model (Fn key codes). Scripts are located here:

http://82.177.165.1/~adi/rozne/

put all *.sh into /etc/acpi/actions/, rest of them into /etc/acpi/events/ , customize them and restart acpid.
Comment 3 Scott Glaser 2009-09-09 08:23:27 EDT
Have you tried with the latest hal package in Fedora 10, Fedora 11 or tried Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Bug Zapper 2009-11-18 04:00:03 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-12-18 01:58:27 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.