Bug 473244 - Mirroring does not work after installation.
Mirroring does not work after installation.
Status: CLOSED DUPLICATE of bug 471689
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
i386 Linux
medium Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 06:01 EST by Krzysztof Wojcik
Modified: 2008-12-03 09:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 05:46:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs (8.51 KB, application/x-zip-compressed)
2008-11-27 06:01 EST, Krzysztof Wojcik
no flags Details

  None (edit)
Description Krzysztof Wojcik 2008-11-27 06:01:06 EST
Created attachment 324859 [details]
Logs

Description: 
Mirroring on RAID1 in RH 5.3 Snap 3 don't work after installation and PC restart.

Steps to reproduce:
1. Create RAID1 in OROM. Use default settings.
2. Boot RH from DVD
3. Choose New Installation. Use default settings on all pages. 
4. On Suggested Partitioning page use configured RAID for installation. 
5. Instalation finish with successfull result (booting and os is working fine)
5. Turn off PC and disconnect second hdd from RAID1 (only first hdd left).
6. Start PC again - OS is starting from only one hdd.
7. Turn off PC and connect second hdd (disconnected 2 steps before) and disconnect first hdd from RAID1 (only second hdd left).
8. Start PC again - OS will start but from strange state- eppears installator which wants to finish installation

Expected results:
OS correctly started (loaded) from both hdd.

Actual results:
OS is starting normally only from one hdd but from next installer wants to finish installation.
It is look like mirroring works only during first stage of installation- after PC restart and finish installation mirroring not works- only one hdd is using to finish installation.

Logs in attachment.

Environment Details:
-OS: RHEL5.3-Server-20081113.1-i386-DVD.iso
-Chipset: ICH9
-CRB: Intel DQ35JO
dmraid version: 1.0.0.rc13 (2007.09.17) debug
dmraid library version: 1.0.0.rc13 (2006.09.17)
device-mapper version: 4.11.5
Comment 1 Hans de Goede 2008-12-02 05:46:41 EST
Krzysztof,

Yes mirroring/raid1 on intel isw does not work in RHEL53 snapshot3, this is a known issue, which is being tracked in bug 471689. The problem is that the initrd fails to bring the raid set online, after which the system boots using just one disk of the set (so no mirroring).

Please do not misunderstand me when I say "this is a known issue", I do NOT mean by saying that, that we do not care about this. Intel ISW raid0 / raid1 not working in the current RHEL53 snapshots is an issue which we take very seriously.

And we've been working hard to fix this, as you can see from the discussion in bug 471689, we believe we've tracked the cause of this down. and we've prepared a fix which will be in snapshot5, which will be made available next Monday.

As I understand that this issue is very important to you, I've made the fixed mkinitrd packages available for you on my personal webspace here:
http://people.atrpms.net/~hdegoede/mkinitrd/

The updated nash one is the one you need, the others might be needed for inter package dependencies.

Using this unfortunately is less then trivial, so you might want to wait till snapshot5 becomes available. If not, you need to do a fresh install and then NOT boot the installed machine, booting will write to one of the 2 disks making the mirror go out of sync, without degrading the raid array, as the OS does not know its a raid array.

Then immediately after the install, start the installer again in rescue mode. Now copy the updated packages to the installed system, and chroot into the installed system.

When chroot-ed into the installed system update nash using rpm, and then do:
mount /proc /proc -t proc
mount /sys /sys -t sysfs
mkinitrd -f /boot/initrd-XXXXX.img XXXXX

Where XXXXX is the version of the exisiting initrd file. Then do:
umount /proc
umount /sysfs
exit
reboot

Now the system should recognize the raid array as such and use both disks.

*** This bug has been marked as a duplicate of bug 471689 ***
Comment 2 Krzysztof Wojcik 2008-12-02 09:14:38 EST
Hans,

Thank you for an in-depth reply.
We are waiting impatiently  for Snapshot 5 to test installation on raid.

Regards

Note You need to log in before you can comment on or make changes to this bug.