Bug 473250 - Can not setup Ms Exchange account if the Mailbox field is filled [NEEDINFO]
Can not setup Ms Exchange account if the Mailbox field is filled
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Barnes
Depends On:
  Show dependency treegraph
Reported: 2008-11-27 06:17 EST by lihuang
Modified: 2014-06-03 08:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-06-03 08:48:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (lihuang)

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 562228 None None None Never

  None (edit)
Description lihuang 2008-11-27 06:17:13 EST
Description of problem:
When setting up an Ms Exchange account, On the Receiving Email Page, if Mailbox field is filled before clicking "Authenticate" button.This account will unavailable even it seems had been set up. you can easily verify by clicking "Send/Receive" tool,Evolution will throw  an Error dialogue :

>Error while Scanning folders in "Exchange server ***". Could not authenticate >to server. ( Password incorrect? )

even with the correct password. 

In another account set up scenario,  I just filled the usename & OWA URL fields, then click "Authenticate" button, the same Mailbox as what I have input in the previous scenario will generate automatically. and this account is available.is it due to my wrongly operation in the previous scenario ?

We have a Ms Exchange server and some accounts for test, If you want to use them,pls tell me

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.launch evolution account assistant.
2.Enter account information and go to Receiving Email page
3.Set server type as  Microsoft Exchange 
4.Enter username/OWA URL/Mailbox
5.Click Authenticate button 
6.Enter the password
7.Follow the assistant to setup account.
8.Close Evolution Preferences window
9.Click "Send/Receive" button on toolbar.
Actual results:
Evolution will throw  an Error dialogue :
Error while Scanning folders in "Exchange server ***". Could not authenticate to server. ( Password incorrect? )

Expected results:
the account should available.

Additional info:
Comment 1 Milan Crha 2008-11-27 09:00:00 EST
Could you try to run evolution-exchange-storage process on terminal and get the debug log from there, in similar way as shown below, with command in terminal:
a) evolution --force-shutdown
b) open terminal for the storage and invoke:
   E2K_DEBUG=5  $PREFIX/libexec/evolution/2.12/evolution-exchange-storage
   (it's supposed to be on one line. The prefix is place where is the package
c) on other terminal run 'evolution'

Try to open the mail folder in the exchange account, maybe enter password again, then it'll probably fail. Close evolution, the exchange-storage-process should stop after few seconds too. Look in the eex.log, delete passwords and/or other sensitive information from there and upload here please. Thanks in advance.
Comment 2 Milan Crha 2008-11-27 09:16:31 EST
Never mind, I see the problem, probably, the URL is damaged, somehow.
Comment 3 Milan Crha 2008-11-27 11:58:22 EST
I posted patch to the upstream bug, and new evolution-data-server-1.12.3-6.el5_2.3 package has been built now.

Changing component to eds too.

I do not know how properly close this, maybe a duplicate of the bug #471215 ?
Comment 4 Lawrence Lim 2008-11-27 19:01:30 EST
Bug 471215 is z-stream though. Will that messed up the nvr?

If they are not related and the risk of not including this patch is low (ie, its ok for customer to wait n they got something which is working), I suggest we push to 5.4.
Comment 5 lihuang 2008-11-27 21:05:11 EST
Verified on evolution-data-server-1.12.3-6.el5_2.3
Comment 9 RHEL Product and Program Management 2014-03-07 07:13:07 EST
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX. To request that Red Hat re-consider this request, please re-open the bugzilla via  appropriate support channels and provide additional business and/or technical details about its importance to you.
Comment 10 RHEL Product and Program Management 2014-06-03 08:48:55 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.