Bug 473278 - docbook2html has wrong (incorrect) default variables
docbook2html has wrong (incorrect) default variables
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: docbook-utils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 09:02 EST by Vegard Nossum
Modified: 2008-12-02 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version: docbook-utils-0.6.14-15.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-27 12:29:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vegard Nossum 2008-11-27 09:02:13 EST
Description of problem:

docbook2html is busted:

$ docbook2html fil.xml 
jw: There is no frontend called "SGML_BASE_DIR=/usr/share/sgml/docbook/utils-0.6.14/frontends/docbook".

If I put --frontend /usr/share/sgml/docbook/utils-0.6.14/frontends/docbook, this particular message disappears, but similar ones for backend, catalog, stylesheet, etc. appear instead.

Version-Release number of selected component (if applicable): docbook-utils-0.6.14-14.fc9.noarch

How reproducible: Always
Comment 1 Ondrej Vasik 2008-11-27 11:13:47 EST
Strange ... it works correctly for me ...
Could you please check:
1)rpm -V docbook-utils

2)rpm -V docbook-dtds 

3)grep ^[:space:]*SGML_BASE_DIR[:space:]*=[:space:]* /etc/sgml/sgml.conf | sed s/^[:space:]*SGML_BASE_DIR[:space:]*=[:space:]*//

It looks like sed on your machine doesn't remove prefix from SGML_BASE_DIR variable when getting from /etc/sgml/sgml.conf
Comment 2 Ondrej Vasik 2008-11-27 11:23:01 EST
as grep/sed requirement is obviously missing in docbook-utils package, missing sed/grep package could be the reason why it doesn't work on your machine correctly
Comment 3 Vegard Nossum 2008-11-27 12:29:39 EST
Aha, I understand what is wrong now. I had this in my .bashrc:

export GREP_OPTIONS="--color=ALWAYS"

(In order to also get colour when piping to "less".)

So this is my own fault. I'm sorry for the false alert! (And thanks for the quick response.)
Comment 4 Ondrej Vasik 2008-11-28 05:53:04 EST
I would not call it only your fault and NOTABUG, it could be prevented by using grep --color=never in jw when getting SGML_BASE_DIR from /etc/sgml/sgml.conf file. Will do that RAWHIDE and F-10, I guess as problem was understood and workaround is easy, there is no need to make update for F-9. Tested with exported GREP_OPTIONS="color=ALWAYS", built as docbook-utils-0.6.14-15.fc11, changing resolution to NEXTRELEASE.
Comment 5 Fedora Update System 2008-11-28 06:02:28 EST
docbook-utils-0.6.14-15.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/docbook-utils-0.6.14-15.fc10
Comment 6 Fedora Update System 2008-12-02 20:12:07 EST
docbook-utils-0.6.14-15.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.