Bug 473279 - ssh and sshd segmentation fault
ssh and sshd segmentation fault
Status: CLOSED DUPLICATE of bug 473073
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 09:05 EST by David Highley
Modified: 2008-11-27 16:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-27 16:47:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of ssh host (22.05 KB, text/x-log)
2008-11-27 09:05 EST, David Highley
no flags Details

  None (edit)
Description David Highley 2008-11-27 09:05:12 EST
Created attachment 324884 [details]
Strace of ssh host

Description of problem:
ssh and sshd segmentation fault

Version-Release number of selected component (if applicable):
openssh-5.1p1-3.fc10.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1.ssh host
2.
3.
  
Actual results:


Expected results:


Additional info:
Attached strace file.
Comment 1 Tomas Mraz 2008-11-27 09:16:17 EST
Please attach a backtrace if you're able to generate it.
Comment 2 David Highley 2008-11-27 09:29:35 EST
[New Thread 0x7ffff7f867a0 (LWP 13723)]
(no debugging symbols found)
(no debugging symbols found)

Program received signal SIGSEGV, Segmentation fault.
0x0000000001886423 in free () from /lib64/libc.so.6
(gdb) where
#0  0x0000000001886423 in free () from /lib64/libc.so.6
#1  0x0000000034175836 in _nss_nis_gethostbyname4_r ()
   from /lib64/libnss_nis.so.2
   #2  0x00000000018d94d6 in gaih_inet () from /lib64/libc.so.6
   #3  0x00000000018db19d in getaddrinfo () from /lib64/libc.so.6
   #4  0x00007ffff7fbe957 in ?? () from /usr/bin/ssh
   #5  0x00007ffff7fb4d5d in main () from /usr/bin/ssh
Comment 3 Tomas Mraz 2008-11-27 11:16:40 EST
I strongly suspect there is some problem in the libnss_nis nsswitch plugin.

Can you please install openssh-debuginfo and glibc-debuginfo and try to obtain the backtrace again?
Comment 4 Emmanuel Thomé 2008-11-27 16:30:27 EST
This is a duplicate of bug 473081 & bug 473073. See patched .so file in 473073, and follow the instructions there to confirm.

E.
Comment 5 Tomas Mraz 2008-11-27 16:47:55 EST

*** This bug has been marked as a duplicate of bug 473073 ***

Note You need to log in before you can comment on or make changes to this bug.