Bug 473294 - closing rxvt-unicode window crashes X
closing rxvt-unicode window crashes X
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rxvt-unicode (Show other bugs)
10
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 09:52 EST by Kai Hambrecht
Modified: 2008-12-02 20:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 20:13:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Hambrecht 2008-11-27 09:52:49 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc10 Firefox/3.0.4

closing a rxvt-unicode terminal window crashes running X session (doesn't matter if it's Gnome, XFCE or LXDE). Get back to GDM login screen.

Reproducible: Always

Steps to Reproduce:
1. from your X session start "urxvt"
2. close urxvt either by typing "exit" or hitting <ctrl-d>
3. X crashes, falling back to GDM login screen
Comment 1 Andreas Bierfert 2008-11-27 12:16:23 EST
Which version of rxvt-unicode are you using?
Comment 2 Kai Hambrecht 2008-11-27 12:24:53 EST
it's rxvt-unicode-9.05-1.fc10.i386 from F10.

I just upgraded from F9 to F10 yesterday. F9 worked fine. This issue happens since F10 upgrade.
Comment 3 Miroslav Lichvar 2008-11-27 12:36:33 EST
I have seen this on a machine with a radeon (RV370) card. Disabling AIGLX in xorg.conf helped, so I'd suspect a bug in the ati driver.

Do you have an ati card?
Comment 4 Andreas Bierfert 2008-11-27 12:51:28 EST
Also there seems to be a bug in libAfterImage so please pull the latest update from updates-testing for both libAfterImage and rxvt-unicode (afaik libAfterImage is not pushed out to the test repo yet).

https://admin.fedoraproject.org/updates/libAfterImage-1.18-2.fc10
https://admin.fedoraproject.org/updates/F10/FEDORA-2008-10240
Comment 5 Kai Hambrecht 2008-11-27 13:10:08 EST
@Miroslav: yes, it's a FireGL Mobility T2 (aka RV350)

@Andreas: suggested updates fixed it (without disabling AIGLX). Thanks.
Comment 6 Andreas Bierfert 2008-11-27 16:55:43 EST
Thanks for the feedback. I will push the new updates to stable.
Comment 7 Fedora Update System 2008-12-02 20:13:15 EST
libAfterImage-1.18-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-12-02 20:24:48 EST
libAfterImage-1.18-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-12-02 20:26:28 EST
libAfterImage-1.18-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.