Bug 473320 - gnome main menu >places> Home folder trying to open xine
gnome main menu >places> Home folder trying to open xine
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 12:32 EST by Deb Mukherjee
Modified: 2015-03-03 17:33 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:59:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wrong inode/directory icon association (29.35 KB, image/png)
2008-12-01 19:14 EST, Deb Mukherjee
no flags Details

  None (edit)
Description Deb Mukherjee 2008-11-27 12:32:54 EST
Description of problem:
Whenever I click on Places>Home folder, instead of launching nautilus gnome tries to launch xine and the memory usage goes upto 80% making the machine slow. Have to issue [ kill 'ps -C xine -o pid=' ] to kill the stray process.
This specific to Home folder as clicking on Places>Computer launches nautilus without any problem. 

Version-Release number of selected component (if applicable):
Gnome 2.24.1, build date 11/06/08

How reproducible:
always

Steps to Reproduce:
1.Go to gnome main menu, navigate to Places [click]
2.Go to home folder [click]

  
Actual results:
Nautilus does not launch and xine starts at the background eating up a lot of memory.

Expected results:
Nautilus lunches, showing home dir.

Additional info:
Comment 1 Ray Strode [halfline] 2008-12-01 13:46:15 EST
If you right click on any folder in a normal nautilus window (not a folder on the desktop) and go to the "Open With" tab you should be able to configure it back to doing the Open Folder action by default.  Does doing that fix your problem?

I suspect we aren't shipping a default entry for inode/directory in defaults.list in shared-mime-info, so it's pick an arbitrary entry out of mimeinfo.cache.  

Just a guess, though.  It could also be that xine is overwriting the default mime action.

Either way, not a gnome-menus bug, so i'm reassigning to shared-mime-info (it may get kicked to xine next)
Comment 2 Deb Mukherjee 2008-12-01 19:14:31 EST
Created attachment 325318 [details]
wrong inode/directory icon association
Comment 3 Deb Mukherjee 2008-12-01 19:15:29 EST
your suggestion in paragraph 1 did not work.

I still think it is a panel related issue because when I am double clicking on home folder from any other location e.g. Places>Computer>File System>home>XXX it is working fine but not when I am clicking Places>home folder. When I do Places>home folder actually what happens? If xine was overwritting the default mime type why only this particular location is affected? 

may be a related issue which has cropped up today is loss of folder icons from nautilus. see attachments.
Comment 4 Deb Mukherjee 2008-12-01 19:28:45 EST
there is no problem with mime action association as when i do this:-

$ cat /usr/share/applications/defaults.list|grep inode

i get this:-

inode/directory=gnome-nautilus-folder-handler.desktop

and still the Places>home folder problem persists.

thanks 
Deb
Comment 5 Ray Strode [halfline] 2008-12-02 11:35:07 EST
what does,

gvfs-open file:///$HOME

do?
Comment 6 Ray Strode [halfline] 2008-12-02 11:37:42 EST
can you attach ~/.local/share/applications/mimeapps.list ?
Comment 7 Deb Mukherjee 2008-12-02 19:17:15 EST
bingo.

$gvfs-open file:///$HOME
[XXX 18:56:01 ~] $ This is xine (X11 gui) - a free video player v0.99.5.
(c) 2000-2007 The xine Team.

$cat ~/.local/share/applications/mimeapps.list
[Added Associations]
inode/directory=userapp-xine-WG7ZIU.desktop;
application/x-extension-dat=rpmfusion-smplayer_enqueue.desktop;
audio/x-vorbis+ogg=totem.desktop;rhythmbox.desktop;redhat-audio-player.desktop;fedora-audacity.desktop;userapp-amarok-JLWFLU.desktop;
image/jpeg=gthumb.desktop;
_______________________________________________________

I commented out the inode/directory line in ~/.local/share/applications/mimeapps.list and issued gvfs-open file:///$HOME which opens the home dir correctly and so does Places>home folder.

to test if installing xine writes in ~/.local/share/applications/mimeapps.list I uninstalled xine and reinstalled it... but it does not!!! do not think it will be xine libs- what can add that line?
Comment 8 Ray Strode [halfline] 2008-12-03 09:33:12 EST
To be honest, I'm not sure how it got written either.  may have been a nautilus issue, or a gvfs issue.  I doubt xine uses the apis that cause that file to get updated.

Now that you've fixed the issue, can you try to reproduce the problem?  (I realize that may be infeasible)

I'm going to throw this report over to nautilus to see if Tomas has any insight.
Comment 9 Jim Henderson 2009-06-19 03:09:12 EDT
Hello Ray,

I have had the same problem as Deb did, except that it was VLC that kept trying to open my Home Folder. Other items in the Places menu would open properly with nautilus. 

My system is Ubuntu Jaunty, so you might like to refer me to a different place to report my experience with this issue. Should I be talking to the Ubuntu folks, or to the GNOME folks?

I installed the system from a CD on 14th June.

Here's what I found in 
   ~/.local/share/applications/mimeapps.list

[Added Associations]
text/html=opera.desktop;
x-content/audio-cdda=vlc.desktop;rhythmbox.desktop;
inode/directory=userapp-vlc-QNVXVU.desktop;nautilus-folder-handler.desktop;userapp-nautilus-AR7PVU.desktop;
x-content/video-dvd=vlc.desktop;

I had not edited this file, but I think this happened because I had tried various methods to associate audio CDs with VLC instead of the default, rhythmbox.

I have a lot of experience on UNIX systems with shell programming, but little experience with system administration using GNOME, so I am still a relative newbie in that. 

I have now fixed the problem by removing the reference to vlc in
   inode/directory
That line is now
   inode/directory=nautilus-folder-handler.desktop;userapp-nautilus-AR7PVU.desktop;

So I've solved my problem, but I feel it would be good if GNOME could provide more information for new users about how to associate an application with audio CDs and DVDs. Can you suggest how I can express this view to the relevant person?

Thanks for your patient support,
   Jim
Comment 10 Tomáš Bžatek 2009-06-19 09:06:50 EDT
I've seen this before, several times. However I have no idea what causes that. So far nobody found a reproducer or given any clue what the root cause could be. This usually happens during upgrade, e.g. users migrating from F10 to F11.
Comment 11 Ray Strode [halfline] 2009-06-19 10:36:24 EDT
I spent some time trying to reproduce this today based on Jim's latest comment and I figured out how to make it happen.

Steps to reproduce:
1) Run nautilus -q
2) gconftool-2 --recursive-unset /apps/nautilus
3) rm -f ~/.local/share/applications/mimeapps.list
4) insert an audio cd into the optical drive
5) Run nautilus
6) Double click on "Computer"
7) Right click on  "Audio Disc"
8) Choose "Properties"
9) Click on the "Open With" tab
10) At this stage you'll notice the bug.  The text says

'Select an application to open "/" and other files of type "folder"'
   o Open Folder

It should say Select an application to open "Audio Disc" and other media of type "x-content/audio-cdda" 

or something.

11) Click Add
12) Select an app (like vlc or gedit or any app that doesn't make sense to open foldres)
13) Click Add
14) Click the radio button next to the newly added item
15) Click Close
16) Go to Places > Home and see it now open incorrectly

So the bug seems to be in step 10.  Nautilus is associating the app with the wrong mime type.
Comment 12 Bug Zapper 2009-11-18 04:00:40 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Bug Zapper 2009-12-18 01:59:11 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 14 Louis van Dyk 2011-02-03 04:08:10 EST
For you info, I am running Fedora 14 x86_64.  I have had the same thing happen somehow ...

$ cat ~/.local/share/applications/mimeapps.list | grep inode

inode/directory=totem.desktop;gnome-nautilus-folder-handler.desktop;userapp-baobab-7IIF8U.desktop;

In my case it opens TOTEM (Movie Player).

I removed the "totem.desktop;" from the inode line and problem is sorted.

*SO* grateful I found this bug report!!

Note You need to log in before you can comment on or make changes to this bug.