Bug 473331 - Can't boot into text mode
Can't boot into text mode
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 14:47 EST by Habig, Alec
Modified: 2008-12-01 09:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-30 01:26:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Habig, Alec 2008-11-27 14:47:54 EST
Installed a brand-new F10 system (on a thinkpad T60p laptop with an R500-series radeon chip) and now can't boot into textmode.  Even with kernel parameters "nofb" and "nomodeswitch", the kernel switches into a framebuffer graphical mode rather than staying in textmode.  The release notes' hint about nomodeswitch does nothing.

Aside from personal preference (I like textmode, it's a nice large font plus fb text scrolling is quite slow), this screws up any attempts to use EXA acceleration with the radeonhd driver later when I want to be in X, since the card has been forced into fb mode (and EXA is where all the acceleration is, so X is also barely usable).

All "plymouth" related rpms have been uninstalled, default runlevel is 3.

The boot logs show the nofb nomodeswitch parameters on the command line properly, but don't elaborate on why they are being ignored.

Also noticed that mkinitrd depends on plymouth, which is a separate bug (getting your kernel to boot with the right drivers shouldn't depend on eye candy, although I understand that plymouth needs to be in the initrd to function).

Am happy to post logs or turn on debugging info, just let me know what info will help.
Comment 1 Dave Jones 2008-11-30 01:26:49 EST
the parameter is nomodeset not nomodeswitch
Comment 2 Habig, Alec 2008-12-01 09:51:55 EST
Doh!  On the bright side, at least closing moronic bug reports like this goes quickly :)

Simply the "nomodeset" kernel parameter alone (did not need "nofb") gets back good old console mode and allows radeonhd's EXA acceleration to work again.

Note You need to log in before you can comment on or make changes to this bug.