Bug 473346 - kernel BUG during boot
kernel BUG during boot
Status: CLOSED DUPLICATE of bug 470215
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 16:40 EST by Derkjan de Haan
Modified: 2009-02-16 17:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 17:50:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derkjan de Haan 2008-11-27 16:40:49 EST
Description of problem:

A kernel BUG shows up during booting the system

Version-Release number of selected component (if applicable):

Linux toshiba.badmuts.org 2.6.27.5-117.fc10.i686 #1 SMP Tue Nov 18 12:19:59 EST 2008 i686 i686 i386 GNU/Linux
Machine is a Toshiba Satellite Pro 2100 laptop

How reproducible:

always

Steps to Reproduce:
1. Install Fedora 10
2. reboot
3. watch the error
  
Actual results:


Expected results:


Additional info:

JBD: barrier-based sync failed on dm-0:8 - disabling barriers
BUG: unable to handle kernel NULL pointer dereference at 0000000c
IP: [<c06a6705>] mutex_lock+0x20/0x2d
*pde = 1e47c067 *pte = 00000000
Oops: 0002 [#1] SMP
Modules linked in: sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 p4_clockmod dm_multipath uinput snd_intel8x0 snd_intel8x0m snd_ac97_codec ac97_bus snd_seq_dummy ppdev snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm smsc_ircc2 irda snd_timer ipw2200 ieee80211 crc_ccitt floppy toshiba_acpi snd pcspkr rfkill iTCO_wdt joydev ieee80211_crypt e100 soundcore iTCO_vendor_support yenta_socket rsrc_nonstatic parport_pc video mii snd_page_alloc output parport input_polldev ata_generic pata_acpi ext4 jbd2 crc16 [last unloaded: microcode]

Pid: 1892, comm: ipolldevd Not tainted (2.6.27.5-117.fc10.i686 #1)
EIP: 0060:[<c06a6705>] EFLAGS: 00010246 CPU: 0
EIP is at mutex_lock+0x20/0x2d
EAX: 0000000c EBX: 0000000c ECX: 00000003 EDX: 00000003
ESI: 00000000 EDI: 0000000c EBP: defa5f50 ESP: defa5f48
 DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Process ipolldevd (pid: 1892, ti=defa5000 task=de693340 task.ti=defa5000)
Stack: c041d8ba 00000000 defa5f64 e087040f e08d8858 e08d8840 de9a01e0 defa5f80
       e08d7875 01000006 01879c00 de9a01e0 defa7200 de9a01f4 defa5f8c e0833154
       de9a01f8 defa5fa8 c0439ea5 defa7204 e0833148 defa7200 defa7204 defa720c
Call Trace:
 [<c041d8ba>] ? need_resched+0x18/0x22
 [<e087040f>] ? rfkill_force_state+0x1e/0x3d [rfkill]
 [<e08d7875>] ? bt_poll_rfkill+0x55/0x8c [toshiba_acpi]
 [<e0833154>] ? input_polled_device_work+0xc/0x32 [input_polldev]
 [<c0439ea5>] ? run_workqueue+0x89/0x113
 [<e0833148>] ? input_polled_device_work+0x0/0x32 [input_polldev]
 [<c0439ffb>] ? worker_thread+0xcc/0xd8
 [<c043cd56>] ? autoremove_wake_function+0x0/0x33
 [<c0439f2f>] ? worker_thread+0x0/0xd8
 [<c043cab3>] ? kthread+0x3b/0x61
 [<c043ca78>] ? kthread+0x0/0x61
 [<c04048f7>] ? kernel_thread_helper+0x7/0x10
 =======================
Code: 31 c0 83 fa 01 0f 94 c0 5b 5d c3 55 ba 58 00 00 00 89 e5 53 89 c3 83 ec 04 b8 38 66 76 c0 e8 7c f7 d7 ff e8 88 fa ff ff 89 d8 90 <ff> 08 79 05 e8 6f 01 00 00 59 5b 5d c3 55 89 e5 57 56 53 89 c3
EIP: [<c06a6705>] mutex_lock+0x20/0x2d SS:ESP 0068:defa5f48
---[ end trace f97ad48a8d6b62ad ]---
Bluetooth: Core ver 2.13
Comment 1 Derkjan de Haan 2008-11-27 16:57:05 EST
Forgot to mention: root FS is on ext4, otherwise it's a more or less default install.
Comment 2 Mace Moneta 2008-12-02 20:57:25 EST
Same on a Toshiba 5105-s607.  This machine does not have built-in 802.11a/b/g or Bluetooth, but variations on the model do.
Comment 3 Derkjan de Haan 2008-12-06 10:05:05 EST
Reinstalled with root FS on XFS, but the bug remains, so it's probably not FS related. In addition to another comment: this laptop has a "Intel Corporation PRO/Wireless 2915ABG" mini-PCI card.
Comment 4 Derkjan de Haan 2009-01-03 12:59:42 EST
FYI: Compiled a stock 2.6.28 kernel using the kernel config file of Fedora kernel 2.6.27.9-159.fc10.i686, and the BUG is gone.
Comment 5 Dennis Jacobfeuerborn 2009-02-12 14:01:14 EST
I'm seeing the same problem on a Toshiba Satellite M30.
Comment 6 Chuck Ebbert 2009-02-16 17:50:30 EST

*** This bug has been marked as a duplicate of bug 470215 ***

Note You need to log in before you can comment on or make changes to this bug.