Bug 473353 - crontabs should own /etc/cron.{hourly,daily,weekly,monthly}
crontabs should own /etc/cron.{hourly,daily,weekly,monthly}
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: crontabs (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan ONDREJ
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 17:39 EST by Fabrice Bellet
Modified: 2008-12-08 08:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 08:02:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrice Bellet 2008-11-27 17:39:05 EST
Hi!

I think crontabs should still own the directories indicated in the summary above, and not let anacron only own them, because when one of these directories is empty, it's removed when upgrading crontabs from f9 to f10, and when executing run-parts from /etc/crontab, crond now fails, telling that one of these directories doesn't exist.

This happens, when :
  . anacron is not installed
  . crontabs is upgraded from f-9 to f-10
  . and one of these directories /etc/cron.xxx is empty before upgrading (when the directory contains something, it isn't deleted, but it is just not owned by any package)
Comment 1 Jan ONDREJ 2008-12-01 02:22:29 EST
Same problem for me. Here is email from cron:

Subject: Cron <root@ns2> run-parts /etc/cron.monthly                            

Not a directory: /etc/cron.monthly

Same problem for other dirs.
Comment 2 Todd Zullinger 2008-12-01 02:41:14 EST
I see this was changed in cvs (only on the F-10 branch).  The dirs should probably be removed from the anacron package as well, since anacron requires crontabs.  And apply this to the devel branch as well, of course. :)
Comment 3 Marcela Mašláňová 2008-12-01 02:43:40 EST
Ok, I'll remove them from anacron.
Comment 4 Jan ONDREJ 2008-12-01 02:44:08 EST
http://koji.fedoraproject.org/koji/buildinfo?buildID=72436

Going to request this for testing in a few minutes.
Comment 5 Fedora Update System 2008-12-01 02:45:24 EST
crontabs-1.10-25.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/crontabs-1.10-25.fc10
Comment 6 Fedora Update System 2008-12-02 20:12:00 EST
crontabs-1.10-25.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update crontabs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10512
Comment 7 Fedora Update System 2008-12-08 08:02:43 EST
crontabs-1.10-25.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.