Bug 473360 - yum will not recognize install DVD as repository because of spaces in name
yum will not recognize install DVD as repository because of spaces in name
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 18:51 EST by stanl
Modified: 2014-01-21 18:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 13:26:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stanl 2008-11-27 18:51:19 EST
Description of problem:After install of Fedora 10 x86_64, using the Fedora 10 install DVD as a repository in the yum.conf file fails because it cannot recognize the URL with the spaces in the name.  I tried escaping the spaces, quoting, double quoting, nothing worked.  Pointed to /media/Fedora 10 x86_64 DVD  That might not be right, for some reason the DVD won't mount right now, so I can't look at the name.  


Version-Release number of selected component (if applicable):
yum-3.2.20-3.fc10.noarch

How reproducible:  Every time


Steps to Reproduce:
1. Add the Fedora 10 x86_64 DVD to the /etc/yum.conf file
2. run yum install or update
3.
  
Actual results:  Complains that repository does not exist.  "" not valid repository


Expected results:  DVD is recognized as a yum repository


Additional info:  Copying the contents of the dvd to a directory path with no spaces in the name allows it to work fine as a repository.  It seems it would be simple to replace the spaces with underscores or dashes to get around this problem.  Or modify yum to look for the trailing / to determine the directory name.
Comment 1 TK009 2008-12-02 22:04:46 EST
This bug has been triaged.
Comment 2 seth vidal 2009-01-21 13:26:45 EST
What did your yum.conf file look like?

For urls - you need to escape the spaces. %20
Comment 3 stanl 2009-01-21 13:40:30 EST
Sorry, that information is gone and I can't remember exactly.

Here is what worked for me.

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
[f10dvd]
name=local-repo
baseurl=file:///web_save/f10dvd/
enabled=1
gpgcheck=0

I copied it from the DVD to the hard drive, giving it a name without spaces and it works fine now.

The original was probably something along the lines of the above with
baseurl=file:///mnt/media/F10 DVD x86_64/

What puzzled me is why the DVD would be named with spaces in the name, causing this problem.  Such a simple fix.

Note You need to log in before you can comment on or make changes to this bug.