Bug 473365 - unable to set resolution on my dell inspiron 4000 to 1024x768
unable to set resolution on my dell inspiron 4000 to 1024x768
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-r128 (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 20:08 EST by Herbert Carl Meyer
Modified: 2009-12-02 19:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 19:28:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf for vesa, 1024x768 (420 bytes, text/plain)
2008-11-28 09:41 EST, Herbert Carl Meyer
no flags Details
log for vesa, 1024x768 (41.99 KB, text/plain)
2008-11-28 09:42 EST, Herbert Carl Meyer
no flags Details
log for no xorg.conf (29.57 KB, text/plain)
2008-11-28 09:58 EST, Herbert Carl Meyer
no flags Details
with Section Screen (24.11 KB, text/plain)
2009-06-04 04:14 EDT, Herbert Carl Meyer
no flags Details
without section screen (28.17 KB, text/plain)
2009-06-04 04:15 EDT, Herbert Carl Meyer
no flags Details

  None (edit)
Description Herbert Carl Meyer 2008-11-27 20:08:32 EST
Description of problem:

I am unable to set resolution on my dell inspiron 4000 to 1024x768

How reproducible: 100%


Steps to Reproduce:
1. install Fedora 10
2. start system
  
Actual results:
Laptop display is 800x600

Expected results:
Laptop display is 1024x768

Additional info:
/var/log/Xorg.0.log contains messages about:
Not using built-in mode "1024x768" (hsync out of range)

well, it worked this morning when it was a rawhide f9 system.

further, adding a minimal /etc/X11/xorg.conf:

Section "Device"
	Identifier  "Videocard0"
	Driver      "vesa"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

using the vesa driver, produces an 800x600 display "window"
in a 1024x768 display. trying the same trick with the r128
driver produces an 800x600 display.
Comment 1 Herbert Carl Meyer 2008-11-27 22:55:24 EST
adding an additional section to xorg.conf:

Section "Monitor"
	Identifier "GenericMonitor"
	Option "DPMS"
	HorizSync 28-51
	VertRefresh 43-60
EndSection

and a corresponding: Monitor "GenericMonitor" in the Screen section has allowed the Preferences > Hardware > Screen Resolution to kick res to 1024x768, with the 
vesa driver.

How is the monitor autodetected ?
Comment 2 Matěj Cepl 2008-11-28 02:56:24 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Herbert Carl Meyer 2008-11-28 09:41:32 EST
Created attachment 324997 [details]
xorg.conf for vesa, 1024x768
Comment 4 Herbert Carl Meyer 2008-11-28 09:42:47 EST
Created attachment 324998 [details]
log for vesa, 1024x768
Comment 5 Herbert Carl Meyer 2008-11-28 09:58:58 EST
Created attachment 325000 [details]
log for no xorg.conf
Comment 6 John Reiser 2008-11-29 11:51:41 EST
I confirm the same problem on the same hardware.  My panel is made by IBM instead of by Samsung, but the specs are the same.

Also, I notice symptoms of a general bug.  The Xorg.0.log contains (separate lines, but in chronological order):
-----
(--) R128(0): Chipset: "ATI Rage 128 Mobility M3 LF (AGP)" (ChipID = 0x4c46)
(**) R128(0): Using flat panel for display
(II) R128(0): Panel size: 1024x768
(II) R128(0): <default monitor>: Using default hsync range of 31.50-37.90 kHz
(II) R128(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
-----
So R128 knows that the panel is 1024x768, and knows that the chipset can drive such a panel, and knows that the display is the panel, but nevertheless chooses a hsync that prevents displaying the native resolution of the panel.  That's a bug.
Comment 7 Mikael Larsson 2009-01-05 05:08:01 EST
I had a similar problem as the one described on this page and have now solved it. However I'm not sure that it will help you but with some luck it may work for you also.

What I discovered, after reading your posts above, is that the xorg engine doesn't seem to be able to activate the higher resolution if the HorizSync and VertRefresh rate isn't set. This is very common to occur since these are not so important values for a flat screen of lap top screen.

I entered the following in my xorg.conf and left anything else to default, i.e. not specifying any driver r128 or vesa. Just the monitor part below.

Section "Monitor"
    Identifier   "Generic Monitor"
    Option       "DPMS"
    HorizSync    31.5-55
    VertRefresh  40-70
EndSection

I hope this will help you as it did me.
Comment 8 Matěj Cepl 2009-06-03 19:44:40 EDT
Reporter, could you check the documentation of your display and card and try to replicate comment 7?

Does it help?
Comment 9 Herbert Carl Meyer 2009-06-04 04:14:08 EDT
Created attachment 346500 [details]
with Section Screen
Comment 10 Herbert Carl Meyer 2009-06-04 04:15:06 EDT
Created attachment 346501 [details]
without section screen
Comment 11 Herbert Carl Meyer 2009-06-04 04:28:41 EDT
Without a Section "Screen" in xorg.conf, X comes up in 800x600. Current xorg.conf is:

Section "Monitor"
	Identifier "GenericMonitor"
	Option "DPMS"
	HorizSync 31.5-55
	VertRefresh 40-70
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "GenericMonitor"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

The attached xorg.0.log (with section screen) and xorg.0.log.old (without section screen) show X is using the r128 driver and mumbles about:

"(II) R128(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)" 
about line 237 (with Section Screen) or 244 (without Section Screen)

and:

(II) R128(0): Modifying mode according to VBIOS: 1024x768 [pclk 65.0 MHz] for FP to: 1024x768 [pclk 65.0 MHz]
about line 293 (with Section Screen)

(II) R128(0): Modifying mode according to VBIOS: 800x600 [pclk 40.0 MHz] for FP to: 800x600 [pclk 65.0 MHz]
about line 300 (without Section Screen)
Comment 12 Bug Zapper 2009-11-18 04:01:13 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Peter Hjalmarsson 2009-11-26 11:59:37 EST
On my laptop F11 still does not work, but after upgrading to F12 it works without a xorg.conf.
Comment 14 Matěj Cepl 2009-11-27 11:50:47 EST
Reporter, are you able to confirm comment 13 (i.e., that this has been fixed in F12)?

Thank you in advance
Comment 15 Herbert Carl Meyer 2009-11-27 14:47:32 EST
no, I cannot confirm it, I no longer have the hardware.
Comment 16 Matěj Cepl 2009-12-02 19:28:35 EST
Since there are insufficient details provided in this report for us to investigate the issue further, and we have not received feedback to the information we have requested above, we cannot continue working on fixing this issue.

Users who have experienced this problem are encouraged to upgrade to the latest update of their distribution, and if this issue turns out to still be reproducible in the latest update, please reopen this bug with additional information.

Closing as INSUFFICIENT_DATA.

Note You need to log in before you can comment on or make changes to this bug.