Bug 473369 - Regression for radeon 9200 going from -58 to -59
Regression for radeon 9200 going from -58 to -59
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 23:02 EST by Bruno Wolff III
Modified: 2009-10-10 15:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-10 15:01:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (104.47 KB, text/plain)
2008-11-27 23:02 EST, Bruno Wolff III
no flags Details
Xorg log file (148.50 KB, text/plain)
2009-01-10 18:12 EST, Vladimir Kotal
no flags Details

  None (edit)
Description Bruno Wolff III 2008-11-27 23:02:01 EST
Created attachment 324934 [details]
Xorg.0.log

Description of problem:
When I went from xorg-x11-drv-ati -58 to -59 I started seeing loss of signal when running glxgears. Ctrl-Alt-Bs would breifly result in the monitor seeing signal but the screen would stay black and then the signal would disappear again. I was able to switch to another VT (though doing a couple of Ctrl-Alt_Bs typically resulted in the console being locked up), so it looks like just X was having a problem (at least initially). I was using the -128 kernel.

Version-Release number of component (if applicable):
xorg-x11-drv-ati-6.9.0-59.fc10.i386
kernel-2.6.27.7-128.fc10.i686

How reproducible:
Seemed to happen pretty often when either letting glxgears run for a while or closing the window with the spinning gears.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I didn't see this behavior with -58.
Comment 1 Bruno Wolff III 2008-11-29 14:21:02 EST
I tried reproducing this with the -130 kernel and where as it happened a lot with -128, a nunber of glxgears tries with -130 worked fine. So maybe it was really a kernel bug or maybe something else. Anyway, at this point there doesn't seem to be a reason to keep this open.
Comment 2 Bruno Wolff III 2008-11-30 16:56:26 EST
I started seeing this again. It doesn't seem to happen as easily when I first saw it but that might have just been being lucky.
I am now using xorg-x11-drv-ati-6.9.0-60.fc10.i386 and kernel-2.6.27.7-132.fc10.i686 and have had X stop working when leaving glxgears run for a while and once during a boot I never had X start working properly. I can sometimes switch to a vt. I tried restarting X using telinit but as above it looks like once it is messed up it is difficult (I haven't succeeded yet.) to get it started again without rebooting.
Comment 3 Bruno Wolff III 2008-12-03 00:10:17 EST
I retested this with the -61 driver and the -135 kernel. After glxgears had been running for about a minute or so the screen froze. Signal remained. I couldn't restart X nor switch to a vt terminal and needed to reboot to fix things.
I am not seeing problems with 2d other than the one case above where something happened during the reboot when I wasn't watching.
Comment 4 Bruno Wolff III 2008-12-08 21:21:23 EST
glxgears is still causing X crash/hang with the -137 kernel.
Comment 5 Bruno Wolff III 2008-12-09 01:02:23 EST
I am still seeing the same symptoms with the -62 driver.
Comment 6 Bruno Wolff III 2008-12-13 11:46:07 EST
I tried out the -152 kernel and I still get a lockup after about 20 seconds of running glxgears.
Comment 7 Bruno Wolff III 2008-12-19 01:28:47 EST
I am still seeing this with kernel 2.6.27.9-163.fc10.i686.
Comment 8 Vladimir Kotal 2009-01-10 18:10:07 EST
I am suffering from this bug too, the signal is lost from time to time, especially when display is refreshed frequently (web page scrolling, playing videos etc.; easily reproducible with glxgears)

The timelines match the observations of bruno@wolff.to.

Currently running with:
xorg-x11-drv-ati-6.9.0-63.fc10.i386
kernel-2.6.27.9-159.fc10.i686

Xorg.log is attached.
Comment 9 Vladimir Kotal 2009-01-10 18:12:05 EST
Created attachment 328641 [details]
Xorg log file
Comment 10 Dave Airlie 2009-01-25 02:51:07 EST
I think we have two bugs, Vladimir please file another bug if your display ever returns, the original bug looks like a GPU hang.

If the display disappears, are you using a DVI connection, does setting

Option "DisplayPriority" "HIGH" in the xorg.conf help?
Comment 11 Bruno Wolff III 2009-01-25 23:58:01 EST
I retested this with xorg-x11-drv-ati-6.10.0-1.fc10.i386 and glxgears still locks up X or the system (I can't tell which from the console).
Comment 12 Vladimir Kotal 2009-01-26 15:52:35 EST
Actually, I am not sure if this hasn't been caused by my motherboard which went dead couple of days after I reported this problem (when the motherboard was still functional, scrolling made the capacitors to emit weird noise which does not add credibility to my earlier bug report). The motherboard is now running with different (albeit Radeon) card so I cannot confirm.
Comment 13 Bruno Wolff III 2009-04-18 03:07:43 EDT
I retested and am still seeing a lock up / crash doing this with:
kernel-2.6.29.1-97.fc11.i686.PAE
xorg-x11-drv-ati-6.12.2-4.fc11.i586
libdrm-2.4.6-6.fc11.i586
mesa--7.5-0.11.fc11
Comment 14 Bruno Wolff III 2009-10-10 15:01:04 EDT
This is no longer happening in rawhide (F12).

Note You need to log in before you can comment on or make changes to this bug.