Bug 473370 - system-config-samba can not modify smb.conf correctly [NEEDINFO]
system-config-samba can not modify smb.conf correctly
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
10
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 23:03 EST by cross
Modified: 2009-12-18 01:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:59:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nphilipp: needinfo? (skurtsev)


Attachments (Terms of Use)
from terminal system-config-samba (1.62 KB, text/plain)
2008-12-03 15:44 EST, Flóki Pálsson
no flags Details
My smb.conf i trayin to change. (9.77 KB, application/octet-stream)
2008-12-03 15:47 EST, Flóki Pálsson
no flags Details

  None (edit)
Description cross 2008-11-27 23:03:46 EST
Description of problem:
Using system-config-samba to delete a shared folder setting will not modify corresponding parts in smb.conf.

Version-Release number of selected component (if applicable):
samba3.2.4,  system-config-samba1.2.67

How reproducible:
Always.

Steps to Reproduce:
1. create a share in system-config-samba
2. the share will not work properly, then delete it from system-config-samba.
3. check smb.conf, the setting for the deleted share remain there.
  
Actual results:
system-config-samba doesn't work for modifying sharing folders setting.

Expected results:
system-config-samba can modify smb.conf properly.

Additional info:
Comment 1 Nils Philippsen 2008-12-03 11:57:09 EST
I just tried tro reproduce the problem, but it worked for me as expected. Do you have any additional information, e.g. are there error messages if you run s-c-samba in a terminal?
Comment 2 Flóki Pálsson 2008-12-03 15:44:35 EST
Created attachment 325593 [details]
from terminal system-config-samba

Run form terminal system-config-samba. root login window opens.  Add file too shaere. quit.  See see attachment.
Nothing is written too smb.conf.  I check with diff. 
I will also attach  my smb.conf, which is from Fedora F9.
Keyboard and language is IS ( iclandic ).
There is a special character in on file name [MP3_lög].
Comment 3 Flóki Pálsson 2008-12-03 15:47:12 EST
Created attachment 325594 [details]
My smb.conf i trayin to change.

This was not a problen in F9.  
My smb.conf i traying to change.
Comment 4 Nils Philippsen 2008-12-04 06:32:44 EST
"cross": I think I've resolved the problem with non-ASCII characters Flóki described, but I'm not quite sure that yours is the same problem...

Do you have any non-ASCII characters in your Samba configuration?

What exactly does "the share will not work properly" mean?

Please do run system-config-samba from the command line and tell me if there are any error messages.
Comment 5 cross 2008-12-04 07:49:57 EST
When I reported this bug, I tried to share same folder both using system-config-samba and nautilus-share, which is using 'net usershare' and this doesn't work for fedora.

So I guess when I remove share settings from system-config-samba, the remained setting for this folder was generated by 'nautilus-share'.

Otherwise, maybe it's from non-ASCII issues, because I am Chinese. Anyway, I will try again, then let you know how it goes.

'the share will not work properly' is my fault, I forget to tick off the samba option in firewall :p
Comment 6 Stuart Finlay 2009-02-16 20:07:02 EST
I'm seeing what I believe to be the same issue as the opening report. 
system-config-samba will happily make additions and changes to smb.conf when started as a normal user (prompted to enter root password) either from the shell or menu however it will not action any deletions.  If it is run as root then all changes happen correctly.  In both cases there are no output errors at the command line.

Not sure if it has any relevance but I also ran nautilus-share at one point but isn't even installed anymore.
Comment 7 Sergey Kurtsev 2009-04-10 17:07:09 EDT
I can confirm the bug at least concerning the issue of non-ASCII characters. Lines with ASCII characters only may be added/edited/deleted correctly. As soon as russian characters are type in (or folder named in Russian) - it becomes impossible to modify/delete the entry.

Samba Version    : 3.2.8
Samba Release    : 0.27.fc10
Comment 8 Nils Philippsen 2009-04-14 07:00:00 EDT
(In reply to comment #7)
> I can confirm the bug at least concerning the issue of non-ASCII characters.
> Lines with ASCII characters only may be added/edited/deleted correctly. As soon
> as russian characters are type in (or folder named in Russian) - it becomes
> impossible to modify/delete the entry.
> 
> Samba Version    : 3.2.8
> Samba Release    : 0.27.fc10  

The Samba version has not bearing here. Which version of system-config-samba do you use?
Comment 9 Bug Zapper 2009-11-18 04:01:18 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-12-18 01:59:42 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.