Bug 473387 - Error in smolt on first boot in Fedora 10 as Linux guest
Error in smolt on first boot in Fedora 10 as Linux guest
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
10
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 03:55 EST by Karl Viklund
Modified: 2009-06-22 15:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 15:37:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karl Viklund 2008-11-28 03:55:22 EST
Description of problem:
After installing the sytem for the first time as a Virtual guest the system shows an error in the smolt module on first boot.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install Fedora 10 release in VirtualBOX 2.0.6 32bit on Windows Vista SP1.
2. Boot the system.
  
Actual results:
Error in smolt in first boot.

Expected results:
Error in smolt in first boot

Additional info:
Alright. I'm no professional Linux guru or a developer. So I don't really know what Information is required. I have reinstalled the system twice with the same result. It's nothing serious. The system just skips the module. I'm subnitting this report because the system asked me so nicely to do so. So if there is any extra information you need I will be happy to give it to you. I have included the special file created containing the report. I hope. The file was named "firstboot-0Xsn3X"
Comment 1 Karl Viklund 2008-11-28 04:03:39 EST
I was unable to include the file but here is what the Error-file contained.
-----------------------------------------------------------------------------

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/firstboot/loader.py", line 87, in loadModules
    loaded = imputil.imp.load_module(module, found[0], found[1], found[2])
  File "/usr/share/firstboot/modules/smolt.py", line 29, in <module>
    t = gettext.translation('smolt', '/usr/share/locale', fallback = True)
  File "/usr/lib/python2.5/gettext.py", line 480, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib/python2.5/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib/python2.5/gettext.py", line 316, in _parse
    plural = v[1].split('plural=')[1]
IndexError: list index out of range
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
"/tmp/firstboot-0Xsn3X" 12L, 688C
Comment 2 Mike McGrath 2008-11-28 10:46:24 EST
interesting.  I'll take a look.  This might actually be a couple of things.  What language were you using?
Comment 3 Christer Lind 2008-11-29 11:00:53 EST
Got the same problem on a Fedora 10 installation, no other os involved. First on an update from Fedora 9, then I tried a new installation with same result.
System config:
CPU Pentium4 2 GHz, 1 GB ram, ATI Radeon 2400, PATA and SATA HDD (PATA boot), language=swedish.
Comment 4 Mike McGrath 2009-06-22 15:37:24 EDT
Ok, thanks for the info, I fixed this a while back I believe but didn't update the ticket (sorry about that)

I think that for future versions of smolt this won't be a problem.  Thanks for the report.
Comment 5 Karl Viklund 2009-06-22 15:42:22 EDT
Good. Thanks.

Note You need to log in before you can comment on or make changes to this bug.