Bug 47340 - Auto-partitioner cannot handle 'no disk label'
Summary: Auto-partitioner cannot handle 'no disk label'
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-04 21:16 UTC by R P Herrold
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-10 22:58:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description R P Herrold 2001-07-04 21:16:59 UTC
Description of Problem:

Auto-=partitioner is baffled by a zeroed (non-labelled) hard drive

How Reproducible:

In a TUI install, a-F2 as soon as it is available by anaconda, and 

dd if=/dev/zero of=/tmp/hda count=10000 bs=512

to well and truly blank the old partition and FAT information away


Actual Results:

Anaconda error, and it dies horribly...


Expected Results:

Offer to label a non-labelled disk

----------------------------

This appeass to be the case with anaconda fdisk in Beta1 as well

Comment 1 Jeremy Katz 2001-07-10 19:54:22 UTC
*** Bug 48421 has been marked as a duplicate of this bug. ***

Comment 2 Jeremy Katz 2001-07-11 03:27:31 UTC
Fixed in internal trees.


Note You need to log in before you can comment on or make changes to this bug.