Bug 473401 - w3c-markup-validator uses incorrect webroot
w3c-markup-validator uses incorrect webroot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 05:29 EST by Gerwin Krist
Modified: 2008-12-01 02:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 02:01:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerwin Krist 2008-11-28 05:29:26 EST
Description of problem:

The package is putting the files in /usr/share/w3c-markup-validator. But the default suexec configuration does not allows scripts being executed from within this directory. So the package will not work without changes.

Version-Release number of selected component (if applicable):
0.8.3-2

How reproducible:
Always

Steps to Reproduce:
1. install w3c-markup-validator
2. restart webserver
3. goto http://127.0.0.1/w3c-validator/check?verbose=1&uri=

Actual results:
Internal error

Expected results:
Some usefull info :)

Additional info:
[root@gerwin Download]# cat /var/log/httpd/suexec.log
[2008-11-28 11:20:42]: uid: (500/gerwin) gid: (500/gerwin) cmd: check
[2008-11-28 11:20:42]: command not in docroot (/usr/share/w3c-markup-validator/cgi-bin/check)
Comment 1 Ville Skyttä 2008-11-30 06:52:42 EST
w3c-markup-validator has been packaged that way for 6 years, and I don't see anything wrong with it.  Maybe httpd-suexec has been unintentionally changed/broken some way in F-10 (I'm still on F-9 so I can't check) - I don't know why suexec would be used for w3c-markup-validator in the first place, it has no setuid or setgid files -> reassigning to httpd.
Comment 2 Gerwin Krist 2008-12-01 02:01:17 EST
After seeing this problem with two F10 machines non-working and 1 F10 machine was working without problem. I thought something must be wrong with the installation.
I removed both httpd packages of the 2 machines and removed the config files, after reinstalling the httpd packages the w3c-markup-validator worked fine!

So Ville you were right! I will try to find the cause why it wasn't working in the first place, but for now this "bug"-report can be closed ....

Note You need to log in before you can comment on or make changes to this bug.