Bug 473408 - Prolonged network blackout during migration of RHEL 4.7
Prolonged network blackout during migration of RHEL 4.7
Status: CLOSED DUPLICATE of bug 460874
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-xen (Show other bugs)
All Linux
medium Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
Depends On:
  Show dependency treegraph
Reported: 2008-11-28 06:22 EST by Ian Campbell
Modified: 2008-12-01 12:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-12-01 12:08:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Use register_netdevice_notifier not register_inetaddr_notifier (1.21 KB, patch)
2008-11-28 06:22 EST, Ian Campbell
no flags Details | Diff

  None (edit)
Description Ian Campbell 2008-11-28 06:22:12 EST
After a live migration of a 2.6.9-78.EL kernel we are seeing network blackouts on the order of several minutes. It appears that the gratuituous ARP is not being sent at all.

In 2.6.9-72.EL RHEL 4 bug #444473 was closed after applying the patch from #441716 comment #5 however #441716 comment #6 points out that this doesn't work due to "silly cut and paste errors" and proposes an updated patch instead, this is the one which is in RHEL 5 currently. I've patched in the difference between the two (basically turning register_inetaddr_notifier into  register_netdevice_notifier) onto 2.6.9-78.0.5.EL and it seems to repair things.
Comment 1 Ian Campbell 2008-11-28 06:22:56 EST
Created attachment 324981 [details]
Use register_netdevice_notifier not register_inetaddr_notifier
Comment 3 Herbert Xu 2008-11-28 07:35:10 EST
Already fixed in 78-15.  As to whether the fix will make it to RHEL4.7 I'm afraid I'm qualified to answer.
Comment 4 Ian Campbell 2008-11-28 08:40:40 EST
Thanks. Is there a bugzilla entry already? I searched before I filed this but didn't find it.
Comment 5 Don Dutile 2008-12-01 12:08:54 EST
the bz that fixed this problem is 460874.

It is being backported to the 4.7-z stream release under bz 469891.

Closing this bz as a dupe of 460874 & 469891.

- Don

*** This bug has been marked as a duplicate of bug 460874 ***

Note You need to log in before you can comment on or make changes to this bug.