Bug 473417 - Race condition between packagekitd and gpk-application
Race condition between packagekitd and gpk-application
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 07:27 EST by Christoph Wickert
Modified: 2008-12-01 08:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-28 09:58:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2008-11-28 07:27:14 EST
Description of problem:
A race condition between packagekitd and gpk-application appears and makes both getting stuck while waiting for each other.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.3.9-8.fc10.i386

How reproducible:
sometimes

Steps to Reproduce:
1. Login
2. Start gpk-application immediately after login
3. Try to install something. I choose a groupinstall of lxde-desktop

Actual results:
gpk-application gets stuck waiting for other tasks endlessly. 

gpk-update-icon says:
Getting repository information (Waiting for other tasks)
Installing LXDE Desktop (Waiting for other tasks)
Reloading package cache (Waiting for other tasks)

gpk-update-icon's tooltip says:
Waiting for other tasks
Waiting for other tasks: installing lxde-desktop
Waiting for other tasks

(not sure if I translated these messages correctly)

Expected results:
Should do one task after the other

Additional info:
I waited for 3 hours and nothing happend. No network traffic, so obviously it's not getting any repository information or anything else. Also no cpu usage.
Comment 1 Richard Hughes 2008-11-28 08:09:48 EST
Can you try the PackageKit in updates-testing please.
Comment 2 Christoph Wickert 2008-11-28 09:58:49 EST
I'd like to, but it crashes:

$ gpk-application 
TI:15:52:16	TH:0x8c693f0	FI:gpk-common.c	FN:gpk_window_set_size_request,60
 - using small form factor mode as 800x600 and requested 1000x500
Traceback:
	gpk-application [0x80592fb]
	gpk-application [0x806dde7]
	gpk-application [0x80546e5]
	/lib/libgobject-2.0.so.0(g_type_create_instance+0x453) [0xd60793]
	/lib/libgobject-2.0.so.0 [0xd44965]
	/lib/libgobject-2.0.so.0(g_object_newv+0x376) [0xd45196]
	/lib/libgobject-2.0.so.0(g_object_new_valist+0x2b7) [0xd45d67]
	/lib/libgobject-2.0.so.0(g_object_new+0x6e) [0xd45ede]
	gpk-application [0x80502de]
	gpk-application [0x804fdc5]
	/lib/libc.so.6(__libc_start_main+0xe5) [0xa636d5]
	gpk-application [0x804faf1]

I have found out that the problem I described has nothing to do with a race condition but the groupinstall simply does not work. With a normal install process I can't reproduce the problem, so I'm closing this bug now and open a proper one for the other problems.
Comment 3 Richard Hughes 2008-12-01 08:02:07 EST
I'm building http://koji.fedoraproject.org/koji/taskinfo?taskID=965965 with that fix. Thanks.

Note You need to log in before you can comment on or make changes to this bug.