Bug 473426 - Cannot Login on Tablet PC !!!!!
Cannot Login on Tablet PC !!!!!
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
: 539430 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 08:29 EST by mail
Modified: 2009-12-02 15:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 04:28:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 164210 None None None Never

  None (edit)
Description mail 2008-11-28 08:29:26 EST
Description of problem:

Cannot Login on Tablet PC

xvkbd (Virtual Keyboard) doesn't accept input from cursor/mouse during greeter/login screen.


Version-Release number of selected component (if applicable):
Fedora 10 (and Fedora 9)


How reproducible:
Easy.
100% failure rate


Steps to Reproduce:
1. Install xvkbd (rpm is readily availably) This is the virtual keyboard.
2. Add the line "xvkbd -always-on-top &" to the bottom of the file /etc/X11/xdm/Xsetup_0
3.Restart X server. 

  
Actual results:

Greeter/login screen will appear with virtual keyboard, but you can't press keys on the virtual keyboard

Expected results:

Greeter/login screen will appear with virtual keyboard, and you can press keys on the virtual keyboard and login successfully.


Additional info:

This has been reported to KDE in June, but nothing has been done. (It was in Fedora 9)
This makes tablet pc's rather useless when even the basic security of passwords are not available or you have to carry around a keyboard - rather defeating the purpose of having a tablet pc !!!
Comment 1 Rex Dieter 2008-11-28 15:50:13 EST
> This has been reported to KDE in June

Details?  bug #?
Comment 2 mail 2008-11-29 01:28:38 EST
Sorry, I put this in External bugs.

kde bug tracking system: bug number 164210.

Here is what I wrote:
I have recently installed Fedora 9 on a Fujitsu ST5110 tablet PC. (This was a fresh install on a machine that was previously running Fedora 7). Fedora 9 includes KDE 4.(I have tried both version 4.0.1 and 4.0.5) There is a problem with KDM and its greeter. I have edited /etc/X11/xdm/Xsetup_0 to launch xvkbd (virtual keyboard) so that I have a keyboard to enter username and password into the greeter login box. (This is what I did in Fedora 7 and KDE3 and this worked perfectly). However, on KDE4 the greeter login box comes to the foreground and my keyboard is hidden. If I launch xvkbd with the option "always-on-top" I can now see the keyboard but I can't press any buttons with the pen/mouse. I can only login using external usb keyboard. Once I have logged in, I can use xvkbd normally - it is just during the greeter login that it won't work. I have tried running kdm without themes and backgrounds, but this made no difference.


Also reported to this site for Fedora 9: Bug id 454282
https://bugzilla.redhat.com/show_bug.cgi?id=454282
Comment 3 Steven M. Parrish 2009-01-09 16:20:09 EST
Thanks for reporting this upstream.  Going to close this as UPSTREAM and will monitor for resolution.
Comment 4 mail 2009-02-02 03:15:16 EST
Can you please not close this upstream.

The kde (kdm) people have had 8 months to take a look at this and nothing has been done.

With the increase in usage of tablet devices - surely this is an issue that needs to be addressed.

Thankyou.
Comment 5 Kevin Kofler 2009-02-02 04:28:00 EST
That doesn't make it any less an upstream issue.
Comment 6 Steven M. Parrish 2009-12-02 15:00:33 EST
*** Bug 539430 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.