Bug 473427 - F10 X does not start properly on Intel 82845 video based system. Worked OK on F9.
F10 X does not start properly on Intel 82845 video based system. Worked OK o...
Status: CLOSED DUPLICATE of bug 478000
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 08:32 EST by Harish Pillay
Modified: 2009-09-06 04:58 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 04:58:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log file (27.00 KB, text/plain)
2008-11-28 08:32 EST, Harish Pillay
no flags Details
lshw of the system (15.73 KB, text/plain)
2008-11-28 08:33 EST, Harish Pillay
no flags Details

  None (edit)
Description Harish Pillay 2008-11-28 08:32:02 EST
Created attachment 324990 [details]
X server log file

Description of problem:

From a functioning F9 did a preupgrade and then a upgrade to 
F10.  All packages as needed were updated.  

Starting X, causes the screen to flash on and off without a
functional X environment.

Version-Release number of selected component (if applicable):

a) latest GA verion of F10.
b) Video is an Intel 82845G/GL [Brookdale-G]/GE chipset integrated graphics device
c) System is Intel(R) Pentium(R) 4 CPU 2.26GHz with 1G RAM.

How reproducible:

Just install F10.  Did not check the system via LiveCD before updating
the system.  After the failure, booting up from F10 LiveCD is not 
successful at all.  Screen is blank when going into graphics mode.

Appending X.log and output from lshw.
Comment 1 Harish Pillay 2008-11-28 08:33:29 EST
Created attachment 324991 [details]
lshw of the system

lshw output of the system.
Comment 2 Matěj Cepl 2008-11-28 10:27:35 EST
(WW) intel(0): Existing errors found in hardware state.
Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x3ffe0001 getbl_err: 0x00000000
ipeir: 0x00000000 iphdr: 0x05000000
LP ring tail: 0x00000050 head: 0x0000001c len: 0x0001f001 start 0x00000000
eir: 0x0000 esr: 0x0000 emr: 0xff7b
instdone: 0xffc1 instpm: 0x0000
memmode: 0x00000000 instps: 0x00000040
hwstam: 0xffff ier: 0x0000 imr: 0xffff iir: 0x0000
Ring at virtual 0xb0013000 head 0x1c tail 0x50 count 13 acthd 0x2d5e8
Ring at virtual 0xb0013000 head 0x1c tail 0x50 count 13
[ ... many identical lines deleted ...]
Ring at virtual 0xb0013000 head 0x1c tail 0x50 count 13
Ring end
space: 131012 wanted 131064
(II) intel(0): [drm] removed 1 reserved context for kernel
(II) intel(0): [drm] unmapping 8192 bytes of SAREA 0xf8d5b000 at 0xb80ab000
(II) intel(0): [drm] Closed DRM master.

Fatal server error:
lockup

_fence_emit_internal: drm_i915_irq_emit: -9
Comment 3 Harish Pillay 2008-11-28 11:01:31 EST
I am changing the severity to urgent as I am now out of a functional Fedora machine.
Comment 4 James Heather 2008-12-01 09:43:00 EST
I can confirm that I have the same problem.

After much mucking about, I have found that

Section "Device"
	Identifier  "Videocard0"
	Driver      "intel"
	Option	    "NoAccel"
EndSection

works for me (the 'NoAccel' bit is the key) but it is so painfully slow that it makes me feel ill.

(To put it in: at the GRUB screen, hit 'a', then append ' 3' to the boot line. This will take you to text-mode login, where you can log in as root, and edit xorg.conf with emacs or another console-based file editor.)

James
Comment 5 Harish Pillay 2008-12-01 11:04:22 EST
Thanks, James for the hint.  It works now after adding the NoAccel option.  I do not seem to encounter any slowness per se.  Tried youtube videos and they seem to be OK.  Will keep a watch on this.  BTW, where did you get that option idea?

Thanks.

Harish
Comment 6 Harish Pillay 2008-12-01 22:02:55 EST
Now that I have added the option as suggested by James, there is a perceptible slowness on the screen.  Scrolling down from and up within say a browser, there is a progressive redraw and line shifting that occurs.  So, the NoAccel option is less that ideal, but atleast X is up and running.

Thanks.

Harish
Comment 7 James Heather 2008-12-02 05:11:38 EST
I can't remember where I found the NoAccel idea, I'm afraid. I would have tracked things a lot more carefully, but I couldn't use my own machine at the time because X wasn't working... so I had to nick someone else's laptop and do a quick bit of searching, and then come back to my machine armed with some ideas. As I recall, the page I found wasn't talking about exactly the same problem, but it was similar enough that its solution seemed worth trying.

Yes, it's the scrolling up and down that's painfully slow. It makes me feel queasy. But then Quake etc. always give me motion sickness, so maybe I'm just a bit wimpish.

James
Comment 8 Harish Pillay 2008-12-08 13:23:39 EST
I thought the updates today to x11-xorg-drv* would fix this problem, but no luck yet.  

BTW, I found where the option "NoAccel" is defined. It is in the man page of
the i810 ("man i810).

/me playing OpenArena is a definite no go.

Harish
Comment 9 Jaime RCZ 2008-12-24 02:04:30 EST
I can also confirm that the "NoAccel" option is the only one that works. Still no fix for this, and I agree that it is painfully slow.

I have an Intel 82845G/GL [Brookdale-G]/GE chipset integrated graphics device
System is Intel(R) Pentium(R) 4 CPU 2.26GHz with 1G RAM.
Comment 10 Joachim Frieben 2008-12-28 04:37:24 EST
(In reply to comment #9)
Using an "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device rev 3", I do not observe any need to disable acceleration, and I have not so for a few weeks already.
However, "Accelmethod" "exa" is required to obtain a usable X at all, thus I have to add something like

 Section "Device"
  Identifier  "Card0"
  Driver      "intel"
  Option      "AccelMethod" "xaa"
 EndSection

in my custom xorg.conf. Currently installed packages include:

 kernel-2.6.27.10-167.fc10.i686
 xorg-x11-drv-i810-2.5.0-4.fc10.i386
 xorg-x11-server-Xorg-1.5.3-6.fc10.i386
Comment 11 Jaime RCZ 2008-12-29 17:16:59 EST
Maybe my 82845 is an older version (rev 01):
Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
and maybe the kernel 2.6.27.10-167 has something to do with it (I'm downloading it right now from koji.fedoraproject.org and will report back).

Anyhow, "AccelMethod" "xaa" does NOT solve the problem with this configuration (which is the current stable one, as far as I know):

 kernel-2.6.27.9-159.fc10.i686
 xorg-x11-drv-i810-2.5.0-4.fc10.i386
 xorg-x11-server-Xorg-1.5.3-6.fc10.i386
Comment 12 Jaime RCZ 2008-12-29 17:55:57 EST
"AccelMethod" "xaa" does NOT work with:

 kernel-2.6.27.10-167.fc10.i686
 xorg-x11-drv-i810-2.5.0-4.fc10.i386
 xorg-x11-server-Xorg-1.5.3-6.fc10.i386

on Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device
(rev 01)

Xorg.log shows:
(WW) intel(0): PRB0_CTL (0x0001f001) indicates ring buffer enabled
(WW) intel(0): PRB0_HEAD (0x0000024c) and PRB0_TAIL (0x00000250) indicate ring buffer not flushed
(WW) intel(0): Existing errors found in hardware state.

Removing all option in Section "Device" does NOT work either. Same result, X freezes a couple of seconds after start up.
Comment 13 Mike C 2009-01-05 09:43:07 EST
This looks similar to #474118 where I reported that using a rebuilt install iso using rpms up to date as at 3rd January 2009 the installer gives a messed up graphics screen on a Dell Dimension 2400 using the 82845G graphics chip from Intel.

What information is needed to progress this bug?
Comment 14 Mike C 2009-01-06 08:00:45 EST
I have now tested an install on a Dimension 2400 which has the 82845G graphics
chipset - the only way I could get a graphical install was to run (using my
updated F10 DVD personal re-spin including updates to 3rd January 2009), and
initiating the install from a grub stansa calling the iso from an HD install,
and including the parameter "xdriver=vesa nomodeset" from the kernel boot line.

This allowed a graphical install and when it got to firstboot I intercepted the
boot and entered the same parameter as above to the kernel line to initiate
firstboot.

This worked and I can then boot the system with the same procedure to run as
"normal" - however the graphics with the vesa driver are far from perfect, and
the screen is fuzzy despite having 1280x1024 resolution set.

I have edited xorg.conf to include the vesa driver and it will boot although
the text mode Plymouth boot line works apart from a brief interruption at an
early stage when the screen blanks for a moment.

system-config-display is not installed by default and this may help a little if
installed and used to reconfigure the display - but the basic problem is that
the driver is buggy and needs fixing.
Comment 15 Mike C 2009-01-06 10:57:02 EST
Once installed by changing xorg.conf to have the "intel" driver and using the "NoAccel" option gives me a normal graphical boot (apart from a short time when the screen goes blank around a third of the way across the Plymouth blue+white line, and I get the correct screen resolution but the graphics performance is poor (eg dragging a terminal window is choppy though it does work).

I could not get the i810 driver to work at all even with the NoAccel option.
Comment 16 Joachim Frieben 2009-01-06 12:20:11 EST
(In reply to comment #15)
> I could not get the i810 driver to work at all even with the NoAccel option.

Well, "i810" and "intel" are 2 names for the same driver, thus the outcome is expected to be the same. What happens when you add

  Option "AccelMethod" "xaa"

in der "Driver" section of xorg.conf instead of using Option "NoAccel"?
Comment 17 Mike C 2009-01-06 12:34:16 EST
Ah - I always wondered what the difference between intel and i810 was - now I know there is no difference!

When I added the Option "AccelMethod" "XAA" to the driver section the machine booted but as soon as X started it showed a cursor at the top left of the screen that was mainly on but slightly flashing, and then after that nothing worked as X had crashed, so I had to reboot. I also could not switch to another tty to get at the log files at the point it crashed either.

I have edited sysctl.conf so that I can use Alt-SysrQ-b to boot - so the kernel is still running at the time of the crash but not X.
Comment 18 Felix Miata 2009-01-07 17:59:49 EST
(In reply to comment #17)
> Ah - I always wondered what the difference between intel and i810 was - now I
> know there is no difference!

It used to be that the intel & i810 drivers were different, but this was changed some months back. I have two systems I haven't even been able test on since F8 due to bug 430836 but now that the .28 kernel should be working around that I need to try again once I know the installer is using .28 or higher. Anyone know? With openSUSE I get different behavior even though both are 845G rev1, one made by Foxconn and in a Dell GX260, and the other made by Intel in a homebuilt.
Comment 19 Gerald Gauthier 2009-01-31 15:52:59 EST
I want to confirm to Joachim Frieben that his suggestion to add "XAA" worked perfectly for me. I was unable to install Fefora 10 or even upgrade from Fedora 9 to 10, even though version 9 worked perfectly on my system. I am running Linux on a Compaq EVO with the Intel 845G chipset.
Comment 20 Vedran Miletić 2009-09-06 04:58:31 EDT
This is very likely a duplicate.

*** This bug has been marked as a duplicate of bug 478000 ***

Note You need to log in before you can comment on or make changes to this bug.